summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOle Jon Bjørkum2017-06-09 12:36:13 +0200
committerOle Jon Bjørkum2017-06-09 12:36:13 +0200
commitbb9d4ac1f68c9b2bd95459ebfadde327078f6954 (patch)
treea69c83d652d0c130d01eff0cd4e9c4ab58a19380
parent037feb5c1983847ef52812874ce5d011adc57e65 (diff)
downloadaur-bb9d4ac1f68c9b2bd95459ebfadde327078f6954.tar.gz
spotify-legacy 0.9.17-2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
2 files changed, 34 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 988bb478aa41..9fe4416c60de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,28 @@
pkgbase = spotify-legacy
pkgdesc = A proprietary music streaming service.
pkgver = 0.9.17
- pkgrel = 2
+ pkgrel = 3
url = https://www.spotify.com/download/linux/
arch = x86_64
license = custom
depends = alsa-lib
+ depends = desktop-file-utils
+ depends = ffmpeg0.10
depends = gconf
- depends = gtk2
depends = glib2
+ depends = gtk2
depends = nss
+ depends = libcurl-compat
depends = libgcrypt15
depends = libsystemd
+ depends = libx11
depends = libxss
+ depends = libxtst
+ depends = nss
+ depends = openssl-1.0
depends = qt4
- optdepends = ffmpeg0.10: Support for playback of local files
- optdepends = zenity: Support for importing local files
+ depends = rtmpdump
+ depends = zenity
provides = spotify=0.9.17
conflicts = spotify
conflicts = spotify-beta
diff --git a/PKGBUILD b/PKGBUILD
index 3328b4f36518..73aff406006e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,34 @@
+# Maintainer: Ole Jon Bjørkum <mail at olejon dot net>
# Contributor: Doug Newgard <scimmia at archlinux dot info>
-# Contributor: Ole Jon Bjørkum <mail at olejon dot net>
pkgname=spotify-legacy
pkgver=0.9.17
-pkgrel=2
+pkgrel=3
pkgdesc="A proprietary music streaming service."
arch=('x86_64')
url="https://www.spotify.com/download/linux/"
license=('custom')
-depends=('alsa-lib' 'gconf' 'gtk2' 'glib2' 'nss' 'libgcrypt15' 'libsystemd' 'libxss' 'qt4')
-optdepends=('ffmpeg0.10: Support for playback of local files'
- 'zenity: Support for importing local files')
+depends=('alsa-lib' 'desktop-file-utils' 'ffmpeg0.10' 'gconf' 'glib2' 'gtk2' 'nss' 'libcurl-compat' 'libgcrypt15' 'libsystemd' 'libx11' 'libxss' 'libxtst' 'nss' 'openssl-1.0' 'qt4' 'rtmpdump' 'zenity')
provides=("spotify=$pkgver")
conflicts=('spotify' 'spotify-beta' 'spotify094' 'spotify-stable')
-source=("http://repository-origin.spotify.com/pool/non-free/s/spotify/spotify-client-${pkgver}_${pkgver}.8.gd06432d.31-1_amd64.deb"
- 'spotify-LICENSE.html::https://www.spotify.com/us/legal/end-user-agreement/')
-md5sums=('69a320368ded33cfcc4e3bb4cc71575c'
- 'SKIP')
-
-package() {
- bsdtar -xf data.tar.xz -C "$pkgdir"
- install -Dm644 spotify-LICENSE.html "$pkgdir/usr/share/licenses/$pkgname/LICENSE.html"
-
- cd "$pkgdir/opt/spotify/spotify-client/"
- install -Dm644 spotify.desktop -t "$pkgdir/usr/share/applications/"
- for res in 16 22 24 32 48 64 128 256 512; do
- install -Dm644 Icons/spotify-linux-$res.png "$pkgdir/usr/share/icons/hicolor/${res}x${res}/apps/spotify-client.png"
- done
- install -Dm644 licenses.xhtml -t "$pkgdir/usr/share/licenses/$pkgname/"
+source=("http://repository-origin.spotify.com/pool/non-free/s/spotify/spotify-client-${pkgver}_${pkgver}.8.gd06432d.31-1_amd64.deb" "spotify-LICENSE.html::https://www.spotify.com/us/legal/end-user-agreement/")
+md5sums=('69a320368ded33cfcc4e3bb4cc71575c' 'SKIP')
+
+package()
+{
+ bsdtar -xf data.tar.xz -C "$pkgdir"
+
+ install -Dm644 spotify-LICENSE.html "$pkgdir/usr/share/licenses/$pkgname/LICENSE.html"
+
+ cd "$pkgdir/opt/spotify/spotify-client/"
+
+ install -Dm644 spotify.desktop -t "$pkgdir/usr/share/applications/"
+
+ for res in 16 22 24 32 48 64 128 256 512; do
+
+ install -Dm644 Icons/spotify-linux-$res.png "$pkgdir/usr/share/icons/hicolor/${res}x${res}/apps/spotify-client.png"
+
+ done
+
+ install -Dm644 licenses.xhtml -t "$pkgdir/usr/share/licenses/$pkgname/"
}