summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Whetter2016-09-22 05:15:55 +0100
committerAshley Whetter2016-09-22 05:15:55 +0100
commit12889684caadcf181b7af4abdb37a568110d723e (patch)
treeade815ee208a0b756a8e1655e66fc5ecb791fd72
parent2519f4262f597ac85aa1bba4eb67c8f6f36237e0 (diff)
downloadaur-12889684caadcf181b7af4abdb37a568110d723e.tar.gz
Updated to version 1.0.38.171
kde protocol file is now always installed
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 15 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07be2f9103aa..5204f16f1684 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spotify
pkgdesc = A proprietary music streaming service
- pkgver = 1.0.37.152
+ pkgver = 1.0.38.171
pkgrel = 1
url = http://www.spotify.com
arch = x86_64
@@ -26,10 +26,10 @@ pkgbase = spotify
source = spotify.protocol
md5sums = cfef2f72647980c639201c6ab39e8534
md5sums = ef25ddc5b6bf8fe1a0d64cbd79e1f7b4
- source_x86_64 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.37.152.gc83ea995-42_amd64.deb
- md5sums_x86_64 = 7fb0b777aa807bd79157f62ca3dc435f
- source_i686 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.37.152.gc83ea995-42_i386.deb
- md5sums_i686 = 3fe48999909ff10b0004dd7a4d845990
+ source_x86_64 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.38.171.g5e1cd7b2-22_amd64.deb
+ md5sums_x86_64 = 085e994bdc09f03b2ceb4cbe81752d75
+ source_i686 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.38.171.g5e1cd7b2-22_i386.deb
+ md5sums_i686 = f6f106ecbb5e8b27616a6f76821d5106
pkgname = spotify
diff --git a/PKGBUILD b/PKGBUILD
index 1fdd9e9213e4..377786f54980 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Eothred <yngve.levinsen@gmail.com>
pkgname=spotify
-pkgver=1.0.37.152
-_anotherpkgver=.gc83ea995
+pkgver=1.0.38.171
+_anotherpkgver=.g5e1cd7b2
pkgrel=1
pkgdesc="A proprietary music streaming service"
arch=('x86_64' 'i686')
@@ -16,11 +16,11 @@ source=('spotify'
md5sums=('cfef2f72647980c639201c6ab39e8534'
'ef25ddc5b6bf8fe1a0d64cbd79e1f7b4')
-source_x86_64=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-42_amd64.deb")
-md5sums_x86_64=('7fb0b777aa807bd79157f62ca3dc435f')
+source_x86_64=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-22_amd64.deb")
+md5sums_x86_64=('085e994bdc09f03b2ceb4cbe81752d75')
-source_i686=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-42_i386.deb")
-md5sums_i686=('3fe48999909ff10b0004dd7a4d845990')
+source_i686=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-22_i386.deb")
+md5sums_i686=('f6f106ecbb5e8b27616a6f76821d5106')
depends=("alsa-lib>=1.0.14" "gconf" "gtk2" "glib2" "nss" "libsystemd" "libxtst" "libx11" "libxss" "libcurl-compat" "desktop-file-utils" "rtmpdump")
optdepends=('ffmpeg0.10: Adds support for playback of local files'
@@ -32,10 +32,8 @@ package() {
tar -xzf data.tar.gz -C "${pkgdir}"
- install -d "${pkgdir}"/usr/share/applications
- install -d "${pkgdir}"/usr/share/pixmaps
- install "${pkgdir}"/usr/share/spotify/spotify.desktop "${pkgdir}"/usr/share/applications/spotify.desktop
- install "${pkgdir}"/usr/share/spotify/icons/spotify-linux-512.png "${pkgdir}"/usr/share/pixmaps/spotify-client.png
+ install -D "${pkgdir}"/usr/share/spotify/spotify.desktop "${pkgdir}"/usr/share/applications/spotify.desktop
+ install -D "${pkgdir}"/usr/share/spotify/icons/spotify-linux-512.png "${pkgdir}"/usr/share/pixmaps/spotify-client.png
for size in 22 24 32 48 64 128 256 512; do
install -D "${pkgdir}/usr/share/spotify/icons/spotify-linux-$size.png" \
@@ -48,9 +46,6 @@ package() {
rm "${pkgdir}"/usr/bin/spotify
install -Dm755 "${srcdir}/spotify" "${pkgdir}/usr/bin/spotify"
- # Copy protocol file if KDE is installed
- if [ -d /usr/share/kservices5 ]; then
- echo "Installing with KDE support"
- install -Dm644 "${srcdir}/spotify.protocol" "${pkgdir}/usr/share/kservices5/spotify.protocol"
- fi
+ # Copy protocol file for KDE
+ install -Dm644 "${srcdir}/spotify.protocol" "${pkgdir}/usr/share/kservices5/spotify.protocol"
}