summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Whetter2016-06-21 22:05:29 +0100
committerAshley Whetter2016-06-21 22:05:29 +0100
commit96249035d018eb00c926a0440aac3775a6d7c790 (patch)
treefaf2666a447a75818ae51094e05e0d0e2947b229
parent78a2eaa509ec198fee07c90ebd9fbe5716f37fb9 (diff)
downloadaur-96249035d018eb00c926a0440aac3775a6d7c790.tar.gz
Updated to version 1.0.32.94
Started installing kde protocol file to kde5 location. Started installing icons.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
2 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e726cb3425c7..a210d62c2b00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spotify
pkgdesc = A proprietary music streaming service
- pkgver = 1.0.31.56
+ pkgver = 1.0.32.94
pkgrel = 1
url = http://www.spotify.com
arch = x86_64
@@ -26,10 +26,10 @@ pkgbase = spotify
source = spotify.protocol
md5sums = 3f843269e92d536cefdd2f68df11f248
md5sums = ef25ddc5b6bf8fe1a0d64cbd79e1f7b4
- source_x86_64 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.31.56.g526cfefe-33_amd64.deb
- md5sums_x86_64 = 8a4c749c95df04fbe7aea6917bf2be8f
- source_i686 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.31.56.g526cfefe-1_i386.deb
- md5sums_i686 = e522f85c96e45a02f4ff43a3103cd4d1
+ source_x86_64 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.32.94.g8a839395-32_amd64.deb
+ md5sums_x86_64 = 9156ec0225ec9453fc2dff7dd21bb392
+ source_i686 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.32.94.g8a839395-2_i386.deb
+ md5sums_i686 = 82e0fb1e839e6a621aee57d42ec30118
pkgname = spotify
diff --git a/PKGBUILD b/PKGBUILD
index 31dfb015fb0d..d512740cdc2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Eothred <yngve.levinsen@gmail.com>
pkgname=spotify
-pkgver=1.0.31.56
-_anotherpkgver=.g526cfefe
+pkgver=1.0.32.94
+_anotherpkgver=.g8a839395
pkgrel=1
pkgdesc="A proprietary music streaming service"
arch=('x86_64' 'i686')
@@ -16,19 +16,19 @@ source=('spotify'
md5sums=('3f843269e92d536cefdd2f68df11f248'
'ef25ddc5b6bf8fe1a0d64cbd79e1f7b4')
-source_x86_64=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-33_amd64.deb")
-md5sums_x86_64=('8a4c749c95df04fbe7aea6917bf2be8f')
+source_x86_64=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-32_amd64.deb")
+md5sums_x86_64=('9156ec0225ec9453fc2dff7dd21bb392')
-source_i686=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-1_i386.deb")
-md5sums_i686=('e522f85c96e45a02f4ff43a3103cd4d1')
+source_i686=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-2_i386.deb")
+md5sums_i686=('82e0fb1e839e6a621aee57d42ec30118')
depends=("alsa-lib>=1.0.14" "gconf" "gtk2" "glib2" "nss" "libsystemd" "libxtst" "libx11" "libxss" "libcurl-compat" "desktop-file-utils" "rtmpdump")
optdepends=('ffmpeg0.10: Adds support for playback of local files'
- 'zenity: Adds support for importing local files'
- )
+'zenity: Adds support for importing local files'
+)
package() {
- cd "${srcdir}"
+ cd "${srcdir}"
tar -xzf data.tar.gz -C "${pkgdir}"
@@ -37,15 +37,20 @@ package() {
install "${pkgdir}"/usr/share/spotify/spotify.desktop "${pkgdir}"/usr/share/applications/spotify.desktop
install "${pkgdir}"/usr/share/spotify/icons/spotify-linux-512.png "${pkgdir}"/usr/share/pixmaps/spotify-client.png
+ for size in 22 24 32 48 64 128 256 512; do
+ install -D "${pkgdir}/usr/share/spotify/icons/spotify-linux-$size.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/spotify.png"
+ done
+
chmod -R go-w "${pkgdir}"/usr
# Bin Script
rm "${pkgdir}"/usr/bin/spotify
install -Dm755 "${srcdir}/spotify" "${pkgdir}/usr/bin/spotify"
- # Copy protocol file if KDE is installed
- if [ -f /usr/bin/startkde ]; then
- echo "Installing with KDE support"
- install -Dm644 "${srcdir}/spotify.protocol" "${pkgdir}/usr/share/kde4/services/spotify.protocol"
- fi
+ # Copy protocol file if KDE is installed
+ if [ -d /usr/share/kservices5 ]; then
+ echo "Installing with KDE support"
+ install -Dm644 "${srcdir}/spotify.protocol" "${pkgdir}/usr/share/kservices5/spotify.protocol"
+ fi
}