summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHailey Somerville2021-08-20 21:53:03 +1000
committerHailey Somerville2021-08-20 21:57:06 +1000
commita8e99eb4e35c19dbadb7c76e4877267d0df3fae0 (patch)
tree038ad28be473792f08631ce1c08362e8f65a57d2
parenta8dc7a5ff2e485db49fcdf3bd85d88fd8d29a594 (diff)
downloadaur-a8e99eb4e35c19dbadb7c76e4877267d0df3fae0.tar.gz
patch xpui.spa to not fetch shows from spotify
inspired by this tweet: https://twitter.com/rem/status/1427546428319150090
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c649e3551dda..99e1ebea59ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,8 @@ pkgbase = spotify-noshows
url = https://www.spotify.com
arch = x86_64
license = custom
+ makedepends = zip
+ makedepends = unzip
depends = alsa-lib>=1.0.14
depends = gtk3
depends = libxss
diff --git a/PKGBUILD b/PKGBUILD
index 66a8dc714a37..24871c18fff0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,6 +16,7 @@ depends=('alsa-lib>=1.0.14' 'gtk3' 'libxss' 'desktop-file-utils' 'openssl' 'nss'
optdepends=('ffmpeg-compat-57: Adds support for playback of local files'
'zenity: Adds support for importing local files'
'libnotify: Desktop notifications')
+makedepends=('zip' 'unzip')
options=('!strip')
# NOTE: We switched from stable to testing on 18th march, as the spotify
@@ -82,4 +83,9 @@ package() {
# Fix permissions
chmod -R go-w "${pkgdir}"
+
+ # Patch to remove shows from homepage
+ unzip -qo "${pkgdir}/opt/spotify/Apps/xpui.spa" xpui.js
+ sed -i 's/,show,/,/' xpui.js
+ zip -qf "${pkgdir}/opt/spotify/Apps/xpui.spa" xpui.js
}