summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Whetter2016-06-23 21:23:20 +0100
committerAshley Whetter2016-06-23 21:23:20 +0100
commitff8b740ce2a38b595273173ae68abcddc009b448 (patch)
treea78d16006a128972128107e2aefee734ae810cef
parent96249035d018eb00c926a0440aac3775a6d7c790 (diff)
downloadaur-ff8b740ce2a38b595273173ae68abcddc009b448.tar.gz
Updated to version 1.0.32.96
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--spotify3
3 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a210d62c2b00..b064802b1dde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spotify
pkgdesc = A proprietary music streaming service
- pkgver = 1.0.32.94
+ pkgver = 1.0.32.96
pkgrel = 1
url = http://www.spotify.com
arch = x86_64
@@ -24,12 +24,12 @@ pkgbase = spotify
options = !upx
source = spotify
source = spotify.protocol
- md5sums = 3f843269e92d536cefdd2f68df11f248
+ md5sums = cfef2f72647980c639201c6ab39e8534
md5sums = ef25ddc5b6bf8fe1a0d64cbd79e1f7b4
- source_x86_64 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.32.94.g8a839395-32_amd64.deb
- md5sums_x86_64 = 9156ec0225ec9453fc2dff7dd21bb392
- source_i686 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.32.94.g8a839395-2_i386.deb
- md5sums_i686 = 82e0fb1e839e6a621aee57d42ec30118
+ source_x86_64 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.32.96.g3c8a06e6-37_amd64.deb
+ md5sums_x86_64 = eeda7b75270106364f1e5042d2b6840e
+ source_i686 = http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_1.0.32.96.g3c8a06e6-3_i386.deb
+ md5sums_i686 = 9b014ea8f1828813d3cbaa2ad5e945d1
pkgname = spotify
diff --git a/PKGBUILD b/PKGBUILD
index d512740cdc2d..41c5bdeb1bad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Eothred <yngve.levinsen@gmail.com>
pkgname=spotify
-pkgver=1.0.32.94
-_anotherpkgver=.g8a839395
+pkgver=1.0.32.96
+_anotherpkgver=.g3c8a06e6
pkgrel=1
pkgdesc="A proprietary music streaming service"
arch=('x86_64' 'i686')
@@ -13,14 +13,14 @@ options=('!strip' '!upx')
source=('spotify'
'spotify.protocol')
-md5sums=('3f843269e92d536cefdd2f68df11f248'
-'ef25ddc5b6bf8fe1a0d64cbd79e1f7b4')
+md5sums=('cfef2f72647980c639201c6ab39e8534'
+ 'ef25ddc5b6bf8fe1a0d64cbd79e1f7b4')
-source_x86_64=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-32_amd64.deb")
-md5sums_x86_64=('9156ec0225ec9453fc2dff7dd21bb392')
+source_x86_64=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-37_amd64.deb")
+md5sums_x86_64=('eeda7b75270106364f1e5042d2b6840e')
-source_i686=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-2_i386.deb")
-md5sums_i686=('82e0fb1e839e6a621aee57d42ec30118')
+source_i686=("http://repository.spotify.com/pool/non-free/s/spotify-client/spotify-client_${pkgver}${_anotherpkgver}-3_i386.deb")
+md5sums_i686=('9b014ea8f1828813d3cbaa2ad5e945d1')
depends=("alsa-lib>=1.0.14" "gconf" "gtk2" "glib2" "nss" "libsystemd" "libxtst" "libx11" "libxss" "libcurl-compat" "desktop-file-utils" "rtmpdump")
optdepends=('ffmpeg0.10: Adds support for playback of local files'
diff --git a/spotify b/spotify
index 47649c94288c..66466e2ed01f 100644
--- a/spotify
+++ b/spotify
@@ -1,2 +1,3 @@
#!/bin/sh
-LD_PRELOAD=libcurl.so.3 /usr/share/spotify/spotify "$@"
+export LD_PRELOAD=libcurl.so.3
+/usr/share/spotify/spotify "$@"