summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThang Pham2021-08-15 20:24:36 +0900
committerThang Pham2021-08-15 20:27:06 +0900
commit67f564b3c62876e0c8284fbcdaf71a4573628509 (patch)
tree6b2ff289584c437e1727131e47a8b0b53542159d
parentbf0dea3405e38c81717556666f4c79ff0e947d44 (diff)
downloadaur-67f564b3c62876e0c8284fbcdaf71a4573628509.tar.gz
remove check function, use `spotify_player` for binary
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 3 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 779e5568f2a8..ed4e50ad85fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spotify-player
pkgdesc = A command driven spotify player.
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/aome510/spotify-player
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 56c6820f962b..4f6e4261b3ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=spotify-player
_gitname=spotify-player
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A command driven spotify player."
arch=("x86_64")
url="https://github.com/aome510/spotify-player"
@@ -18,15 +18,9 @@ build() {
cargo build --release --locked --all-features --target-dir=target
}
-check() {
- cd "${_gitname}-$pkgver"
-
- cargo test --release --locked --target-dir=target
-}
-
package() {
cd "${_gitname}-$pkgver"
- install -Dm755 target/release/${pkgname} -t "${pkgdir}/usr/bin"
+ install -Dm755 target/release/spotify_player -t "${pkgdir}/usr/bin"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}