summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThang Pham2021-08-15 20:13:33 +0900
committerThang Pham2021-08-15 20:13:33 +0900
commitbf0dea3405e38c81717556666f4c79ff0e947d44 (patch)
tree9669e0a2856101722c86ab9e7e5a01db6ec19ac8
downloadaur-bf0dea3405e38c81717556666f4c79ff0e947d44.tar.gz
add spotify-player v0.1.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD32
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..779e5568f2a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = spotify-player
+ pkgdesc = A command driven spotify player.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/aome510/spotify-player
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ source = spotify-player-0.1.0.tar.gz::https://github.com/aome510/spotify-player/archive/v0.1.0.tar.gz
+ sha512sums = d629170f71bf06d25fa0f1f97b4ce31364152770017a8825c1d771177d6e28ac6dff9c6d8c4a5d01795a2372a14ce4109e40b0d3dc0753788bc60984a79a5ff8
+
+pkgname = spotify-player
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56c6820f962b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Thang Pham <phamducthang1234 at gmail dot com>
+
+pkgname=spotify-player
+_gitname=spotify-player
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A command driven spotify player."
+arch=("x86_64")
+url="https://github.com/aome510/spotify-player"
+license=('MIT')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/aome510/spotify-player/archive/v$pkgver.tar.gz")
+sha512sums=('d629170f71bf06d25fa0f1f97b4ce31364152770017a8825c1d771177d6e28ac6dff9c6d8c4a5d01795a2372a14ce4109e40b0d3dc0753788bc60984a79a5ff8')
+
+build() {
+ cd "${_gitname}-$pkgver"
+
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+check() {
+ cd "${_gitname}-$pkgver"
+
+ cargo test --release --locked --target-dir=target
+}
+
+package() {
+ cd "${_gitname}-$pkgver"
+
+ install -Dm755 target/release/${pkgname} -t "${pkgdir}/usr/bin"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}