summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2020-10-31 17:12:10 -0700
committerXavierCLL2020-10-31 17:12:10 -0700
commit523c2548025028d154957df18312ef29cdbd19c7 (patch)
tree9d830c5e691fed80ea0600da64c17538f1f26501
parentcbfa645f06aaabf43fda3602093814554df483bf (diff)
downloadaur-523c2548025028d154957df18312ef29cdbd19c7.tar.gz
Updated and fixed
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD19
-rwxr-xr-x[-rw-r--r--]setup.py28
3 files changed, 34 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a4283b6db4c..c32f78b42e47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = spotify-ripper
pkgdesc = Command-line ripper for Spotify, with a workaround for playlist emptying
- pkgver = 2.11
- pkgrel = 5
- url = https://github.com/wolfmanx/spotify-ripper/tree/pr-collect
+ pkgver = 2.14
+ pkgrel = 1
+ url = https://github.com/scaronni/spotify-ripper
arch = any
license = MIT
- makedepends = python2-setuptools
- depends = python2
- depends = python2-spotify
- depends = mutagen
- depends = python2-colorama
- depends = python2-requests
- depends = python2-schedule
- depends = python2-spotipy
+ makedepends = python-setuptools
+ makedepends = libspotify
+ depends = python
+ depends = python-spotify
+ depends = python-spotipy
+ depends = python-mutagen
+ depends = python-colorama
+ depends = python-requests
+ depends = python-schedule
depends = lame
optdepends = flac: Rip songs to lossless FLAC encoding
optdepends = opus-tools: Rip songs to Opus encoding
@@ -20,11 +21,11 @@ pkgbase = spotify-ripper
optdepends = faac: Rip songs to AAC format with FreeAAC
optdepends = libav-git-no-libs: Rip songs to Apple Lossless format
optdepends = fdkaac: Rip songs to MP4/M4A format with Fraunhofer FDK AAC codec
- source = https://github.com/wolfmanx/spotify-ripper/archive/pr-collect.zip
+ source = https://github.com/scaronni/spotify-ripper/archive/2.14.tar.gz
source = setup.py
source = requirements.txt
- md5sums = SKIP
- md5sums = c80e4dc2d35501cc87ef75deb954a3c0
+ md5sums = 347411bf137546432443f143f21221bd
+ md5sums = 2c3e897ce5cf74e0cf2db5cbf1890371
md5sums = 433ec722cffccd32c7e31807262f1128
pkgname = spotify-ripper
diff --git a/PKGBUILD b/PKGBUILD
index 7ccd365b64e1..198bd2bbee49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: XavierCLL <xavier.corredor.llano (a) gmail.com>
pkgname=spotify-ripper
-pkgver=2.11
-pkgrel=5
+pkgver=2.14
+pkgrel=1
pkgdesc='Command-line ripper for Spotify, with a workaround for playlist emptying'
arch=('any')
-url="https://github.com/wolfmanx/spotify-ripper/tree/pr-collect"
+url="https://github.com/scaronni/spotify-ripper"
license=('MIT')
-depends=('python2' 'python2-spotify' 'mutagen' 'python2-colorama' 'python2-requests'
- 'python2-schedule' 'python2-spotipy' 'lame')
+depends=('python' 'python-spotify' 'python-spotipy' 'python-mutagen' 'python-colorama' 'python-requests' 'python-schedule' 'lame')
optdepends=('flac: Rip songs to lossless FLAC encoding' 'opus-tools: Rip songs to Opus encoding'
'vorbis-tools: Rip songs to Ogg Vorbis encoding' 'faac: Rip songs to AAC format with FreeAAC'
'libav-git-no-libs: Rip songs to Apple Lossless format' 'fdkaac: Rip songs to MP4/M4A format with Fraunhofer FDK AAC codec')
-makedepends=('python2-setuptools')
-source=("https://github.com/wolfmanx/spotify-ripper/archive/pr-collect.zip"
+makedepends=('python-setuptools' 'libspotify')
+source=("https://github.com/scaronni/spotify-ripper/archive/${pkgver}.tar.gz"
"setup.py" "requirements.txt")
-md5sums=('SKIP'
- 'c80e4dc2d35501cc87ef75deb954a3c0'
+md5sums=('347411bf137546432443f143f21221bd'
+ '2c3e897ce5cf74e0cf2db5cbf1890371'
'433ec722cffccd32c7e31807262f1128')
package() {
@@ -26,5 +25,5 @@ package() {
cp ../setup.py .
cp ../requirements.txt .
- python2 setup.py install --root="$pkgdir"
+ python setup.py install --root="$pkgdir"
}
diff --git a/setup.py b/setup.py
index 5a174a13c04a..f78c0eed64a6 100644..100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
# coding=utf-8
from setuptools import setup, find_packages
@@ -6,11 +6,9 @@ import os
def create_default_dir():
- default_dir = os.path.normpath(os.path.realpath(
- (os.path.join(os.path.expanduser("~"), ".spotify-ripper"))))
+ default_dir = os.path.normpath(os.path.realpath((os.path.join(os.path.expanduser("~"), ".spotify-ripper"))))
if not os.path.exists(default_dir):
- print("Creating default settings directory: " +
- default_dir)
+ print("Creating default settings directory: " + default_dir)
os.makedirs(default_dir.encode("utf-8"))
@@ -20,7 +18,7 @@ def _read(fn):
setup(
name='spotify-ripper',
- version='2.11',
+ version='2.14',
packages=find_packages(exclude=["tests"]),
#scripts=['spotify_ripper/main.py'],
include_package_data=True,
@@ -35,7 +33,7 @@ setup(
# Additional data
package_data={
- '': ['README.rst', 'LICENCE']
+ '': ['README.md', 'LICENSE']
},
# Requirements
@@ -49,26 +47,20 @@ setup(
],
# Metadata
- author='James Newell, SolidHal',
- author_email='james.newell@gmail.com',
- description='a small ripper for Spotify that rips Spotify URIs '
- 'to audio files',
+ author='Simone Caronni',
+ author_email='negativo17@gmail.com',
+ description='A small ripper for Spotify that rips Spotify URIs to media files',
license='MIT',
keywords="spotify ripper mp3 ogg vorbis flac opus acc mp4 m4a",
- url='https://github.com/SolidHal/spotify-ripper',
- download_url='https://github.com/SolidHal/spotify-ripper/archive/2.11.tar.gz',
+ url='https://github.com/scaronni/spotify-ripper',
+ download_url='https://github.com/scaronni/spotify-ripper/tarball/2.14',
classifiers=[
'Topic :: Multimedia :: Sound/Audio',
'Topic :: Multimedia :: Sound/Audio :: Capture/Recording',
'License :: OSI Approved :: MIT License',
'Environment :: Console',
- "Intended Audience :: Developers",
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
],
- #long_description=_read('README.rst'),
)
create_default_dir()