summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2018-08-15 22:32:25 -0500
committerXavierCLL2018-08-15 22:32:25 -0500
commitd564a0d4d5b86a2195f513011caff6e5c51cee90 (patch)
tree60a7cac4f086c1f298e089c117fd4cbc16a3e5fd
parent8a5c8456ee3538e5dd19ea0355d1cb4b4117d6f4 (diff)
downloadaur-d564a0d4d5b86a2195f513011caff6e5c51cee90.tar.gz
Fix depends, update sources and delete old fixed requires
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--requirements.txt5
-rwxr-xr-xsetup.py73
4 files changed, 15 insertions, 101 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54c0873eb210..e772df2f1107 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = spotify-ripper
pkgdesc = Command-line ripper for Spotify, with a workaround for playlist emptying
pkgver = 2.11
- pkgrel = 2
- url = https://github.com/SolidHal/spotify-ripper
+ pkgrel = 3
+ url = https://github.com/colorizedmind/spotify-ripper
arch = any
license = MIT
makedepends = python2-setuptools
depends = python2
+ depends = python2-spotify
depends = mutagen
- depends = python2-pyspotify
depends = python2-colorama
depends = python2-requests
depends = python2-schedule
@@ -20,12 +20,8 @@ pkgbase = spotify-ripper
optdepends = faac: Rip songs to AAC format with FreeAAC
optdepends = libav-git-no-libs: Rip songs to Apple Lossless format
optdepends = fdkaac: Rip songs to MP4/M4A format with Fraunhofer FDK AAC codec
- source = https://github.com/SolidHal/spotify-ripper/archive/2.11.zip
- source = setup.py
- source = requirements.txt
- md5sums = 9e15172c41c80eb46b149a3799f9e66a
- md5sums = 2cc746f3bb1ed00e8bc7dc053829f5dc
- md5sums = 433ec722cffccd32c7e31807262f1128
+ source = https://github.com/colorizedmind/spotify-ripper/archive/a044a2ee8ce9d42f43ec973a2480ec5f62598ae7.zip
+ md5sums = 0365af83b46ad43c6331cb7887ed06f8
pkgname = spotify-ripper
diff --git a/PKGBUILD b/PKGBUILD
index e03d05f41466..96f755bddea4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,21 @@
pkgname=spotify-ripper
pkgver=2.11
-pkgrel=2
+pkgrel=3
pkgdesc='Command-line ripper for Spotify, with a workaround for playlist emptying'
arch=('any')
-url="https://github.com/SolidHal/spotify-ripper"
+url="https://github.com/colorizedmind/spotify-ripper"
license=('MIT')
-depends=('python2' 'mutagen' 'python2-pyspotify' 'python2-colorama' 'python2-requests' 'python2-schedule' 'python2-spotipy' 'lame')
-optdepends=('flac: Rip songs to lossless FLAC encoding' 'opus-tools: Rip songs to Opus encoding' 'vorbis-tools: Rip songs to Ogg Vorbis encoding' 'faac: Rip songs to AAC format with FreeAAC' 'libav-git-no-libs: Rip songs to Apple Lossless format' 'fdkaac: Rip songs to MP4/M4A format with Fraunhofer FDK AAC codec')
+depends=('python2' 'python2-spotify' 'mutagen' 'python2-colorama' 'python2-requests'
+ 'python2-schedule' 'python2-spotipy' 'lame')
+optdepends=('flac: Rip songs to lossless FLAC encoding' 'opus-tools: Rip songs to Opus encoding'
+ 'vorbis-tools: Rip songs to Ogg Vorbis encoding' 'faac: Rip songs to AAC format with FreeAAC'
+ 'libav-git-no-libs: Rip songs to Apple Lossless format' 'fdkaac: Rip songs to MP4/M4A format with Fraunhofer FDK AAC codec')
makedepends=('python2-setuptools')
-source=("https://github.com/SolidHal/spotify-ripper/archive/$pkgver.zip"
- "setup.py" "requirements.txt")
-md5sums=('9e15172c41c80eb46b149a3799f9e66a'
- '2cc746f3bb1ed00e8bc7dc053829f5dc'
- '433ec722cffccd32c7e31807262f1128')
+source=("https://github.com/colorizedmind/spotify-ripper/archive/a044a2ee8ce9d42f43ec973a2480ec5f62598ae7.zip")
+md5sums=('0365af83b46ad43c6331cb7887ed06f8')
package() {
- # fix imports
- cp setup.py $pkgname-$pkgver/
- cp requirements.txt $pkgname-$pkgver/
-
- cd "$pkgname-$pkgver"
+ cd $pkgname-*
python2 setup.py install --root="$pkgdir"
}
diff --git a/requirements.txt b/requirements.txt
deleted file mode 100644
index 6204e4dc47cf..000000000000
--- a/requirements.txt
+++ /dev/null
@@ -1,5 +0,0 @@
-pyspotify
-colorama
-mutagen
-requests
-schedule
diff --git a/setup.py b/setup.py
deleted file mode 100755
index bcc06861fe6b..000000000000
--- a/setup.py
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/usr/bin/env python
-# coding=utf-8
-
-from setuptools import setup, find_packages
-import os
-
-
-def create_default_dir():
- default_dir = os.path.normpath(os.path.realpath(
- (os.path.join(os.path.expanduser("~"), ".spotify-ripper"))))
- if not os.path.exists(default_dir):
- print("Creating default settings directory: " +
- default_dir)
- os.makedirs(default_dir.encode("utf-8"))
-
-
-def _read(fn):
- path = os.path.join(os.path.dirname(__file__), fn)
- return open(path).read()
-
-setup(
- name='spotify-ripper',
- version='2.11',
- packages=find_packages(exclude=["tests"]),
- scripts=['spotify_ripper/main.py'],
- include_package_data=True,
- zip_safe=False,
-
- # Executable
- entry_points={
- 'console_scripts': [
- 'spotify-ripper = main:main',
- ],
- },
-
- # Additional data
- package_data={
- '': ['README.rst', 'LICENCE']
- },
-
- # Requirements
- install_requires=[
- 'pyspotify',
- 'colorama',
- 'mutagen',
- 'requests',
- 'schedule',
- ],
-
- # Metadata
- author='James Newell, SolidHal',
- author_email='james.newell@gmail.com',
- description='a small ripper for Spotify that rips Spotify URIs '
- 'to audio files',
- license='MIT',
- keywords="spotify ripper mp3 ogg vorbis flac opus acc mp4 m4a",
- url='https://github.com/SolidHal/spotify-ripper',
- download_url='https://github.com/SolidHal/spotify-ripper/archive/2.11.tar.gz',
- classifiers=[
- 'Topic :: Multimedia :: Sound/Audio',
- 'Topic :: Multimedia :: Sound/Audio :: Capture/Recording',
- 'License :: OSI Approved :: MIT License',
- 'Environment :: Console',
- "Intended Audience :: Developers",
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
- ],
- long_description=_read('README.rst'),
-)
-
-create_default_dir()