summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2017-01-27 18:46:33 -0500
committerXavierCLL2017-01-27 18:46:33 -0500
commite9d2cf4235d6080df602d0f900306d2c2225118e (patch)
tree9cec5349f15ad52ba47562d985c6da21f0173b77
parentc58b62c1829b6401964750e4332fc3cadcfdb05e (diff)
downloadaur-e9d2cf4235d6080df602d0f900306d2c2225118e.tar.gz
Updated version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e833d5665ba1..3861f51e2f6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Fri Jan 27 23:45:02 UTC 2017
pkgbase = spotify-ripper
- pkgdesc = a small ripper for Spotify that rips Spotify URIs to audio files
- pkgver = 2.9.1
+ pkgdesc = Command-line ripper for Spotify, with a workaround for playlist emptying
+ pkgver = 2.11
pkgrel = 1
- url = https://github.com/jrnewell/spotify-ripper
+ url = https://github.com/SolidHal/spotify-ripper
arch = any
license = MIT
makedepends = python2-setuptools
@@ -12,6 +14,7 @@ pkgbase = spotify-ripper
depends = python2-mutagen-1.30
depends = python2-requests>=2.3.0
depends = python2-schedule>=0.3.1
+ depends = python2-spotipy
depends = lame
optdepends = flac: Rip songs to lossless FLAC encoding
optdepends = opus-tools: Rip songs to Opus encoding
@@ -19,8 +22,8 @@ pkgbase = spotify-ripper
optdepends = faac: Rip songs to AAC format with FreeAAC
optdepends = libav-git-no-libs: Rip songs to Apple Lossless format
optdepends = fdkaac: Rip songs to MP4/M4A format with Fraunhofer FDK AAC codec
- source = https://github.com/jrnewell/spotify-ripper/archive/2.9.1.zip
- md5sums = b88f7a7336c67da7428672d94ee24827
+ source = https://github.com/SolidHal/spotify-ripper/archive/2.11.zip
+ md5sums = 9e15172c41c80eb46b149a3799f9e66a
pkgname = spotify-ripper
diff --git a/PKGBUILD b/PKGBUILD
index 48c13f5bc67c..6c9cf6b548ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
-# Maintainer: bluemeda <affif[dot]bluemeda[at]gmail[dot]com>
_name=spotify-ripper
pkgname=spotify-ripper
-pkgver=2.9.1
+pkgver=2.11
pkgrel=1
-pkgdesc='a small ripper for Spotify that rips Spotify URIs to audio files'
+pkgdesc='Command-line ripper for Spotify, with a workaround for playlist emptying'
arch=('any')
-url="https://github.com/jrnewell/$_name"
+url="https://github.com/SolidHal/$_name"
license=('MIT')
-depends=('python2' 'python2-pyspotify=2.0.5' 'python2-colorama-0.3.3' 'python2-mutagen-1.30' 'python2-requests>=2.3.0' 'python2-schedule>=0.3.1' 'lame')
+depends=('python2' 'python2-pyspotify=2.0.5' 'python2-colorama-0.3.3' 'python2-mutagen-1.30' 'python2-requests>=2.3.0' 'python2-schedule>=0.3.1' 'python2-spotipy' 'lame')
optdepends=('flac: Rip songs to lossless FLAC encoding' 'opus-tools: Rip songs to Opus encoding' 'vorbis-tools: Rip songs to Ogg Vorbis encoding' 'faac: Rip songs to AAC format with FreeAAC' 'libav-git-no-libs: Rip songs to Apple Lossless format' 'fdkaac: Rip songs to MP4/M4A format with Fraunhofer FDK AAC codec')
makedepends=('python2-setuptools')
-source=("https://github.com/jrnewell/spotify-ripper/archive/"$pkgver".zip")
-md5sums=('b88f7a7336c67da7428672d94ee24827')
+source=("https://github.com/SolidHal/spotify-ripper/archive/"$pkgver".zip")
+md5sums=('9e15172c41c80eb46b149a3799f9e66a')
package() {
cd "$srcdir/$_name-$pkgver"