summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoribrokemypie2017-10-09 16:57:45 +1100
committeribrokemypie2017-10-09 16:57:45 +1100
commit8d6217ce65cdca0320cd2d7e4e40d44f043b1810 (patch)
tree0ca53cf6360610ba3ee2d2dba15b861392aff35e
downloadaur-8d6217ce65cdca0320cd2d7e4e40d44f043b1810.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD26
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01aba038275a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = spotify-ripper-git
+ pkgdesc = Command-line ripper for Spotify, with a workaround for playlist emptying
+ pkgver = r451.d046419
+ pkgrel = 1
+ url = https://github.com/hbashton/spotify-ripper
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ makedepends = git
+ depends = python2
+ depends = python2-pyspotify=2.0.5
+ depends = python2-colorama-0.3.3
+ depends = python2-mutagen-1.30
+ depends = python2-requests>=2.3.0
+ depends = python2-schedule>=0.3.1
+ optdepends = lame: Rip songs to mp3
+ optdepends = flac: Rip songs to lossless FLAC encoding
+ optdepends = opus-tools: Rip songs to Opus encoding
+ optdepends = vorbis-tools: Rip songs to Ogg Vorbis encoding
+ optdepends = faac: Rip songs to AAC format with FreeAAC
+ optdepends = libav-git-no-libs: Rip songs to Apple Lossless format
+ optdepends = fdkaac: Rip songs to MP4/M4A format with Fraunhofer FDK AAC codec
+ source = git+https://github.com/hbashton/spotify-ripper
+ sha256sums = SKIP
+
+pkgname = spotify-ripper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4155c7d0b0df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=spotify-ripper-git
+pkgver=r451.d046419
+pkgrel=1
+pkgdesc='Command-line ripper for Spotify, with a workaround for playlist emptying'
+arch=('any')
+url="https://github.com/hbashton/spotify-ripper"
+license=('MIT')
+depends=('python2' 'python2-pyspotify=2.0.5' 'python2-colorama-0.3.3' 'python2-mutagen-1.30' 'python2-requests>=2.3.0' 'python2-schedule>=0.3.1')
+optdepends=('lame: Rip songs to mp3' 'flac: Rip songs to lossless FLAC encoding' 'opus-tools: Rip songs to Opus encoding' 'vorbis-tools: Rip songs to Ogg Vorbis encoding' 'faac: Rip songs to AAC format with FreeAAC' 'libav-git-no-libs: Rip songs to Apple Lossless format' 'fdkaac: Rip songs to MP4/M4A format with Fraunhofer FDK AAC codec')
+makedepends=('python2-setuptools' 'git')
+source=("git+https://github.com/hbashton/spotify-ripper")
+sha256sums=('SKIP')
+_name=spotify-ripper
+
+pkgver() {
+ cd "$_name"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$_name"
+ python2 setup.py install --root="$pkgdir"
+}