summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-02-22 18:21:13 +0100
committerFabioLolix2022-02-22 18:21:13 +0100
commitb87e16c4ce271c806a4d3bd703260e385bccd54e (patch)
tree9f9074644f6483595ddfee3ab1d4f0f3d410dd5e
parentb906e0bc1f41936c300eebe18d8b89c1714af7bd (diff)
downloadaur-b87e16c4ce271c806a4d3bd703260e385bccd54e.tar.gz
revision
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD31
2 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79e1a1f00a2c..0342c7262450 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = spotify-tui-git
- pkgdesc = Spotify client for the terminal written in Rust (git)
- pkgver = 0.16.0+r2+gdf3b6c3
+ pkgdesc = Spotify client for the terminal written in Rust
+ pkgver = 0.25.0.r15.gc4dcf6b
pkgrel = 1
url = https://github.com/Rigellute/spotify-tui
arch = x86_64
license = MIT
makedepends = git
makedepends = cargo
- makedepends = python
+ depends = gcc-libs
depends = openssl
- depends = libxcb
provides = spotify-tui
conflicts = spotify-tui
- source = git+https://github.com/Rigellute/spotify-tui
+ source = git+https://github.com/Rigellute/spotify-tui.git
sha512sums = SKIP
pkgname = spotify-tui-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 63740291f81e..4cad6a62c0d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,35 @@
-# Maintainer: Simon Hauser <Simon-Hauser@outlook.de>
+# Maintainer:
+# Contributor: FabioLolix
+# Contributor: Simon Hauser <Simon-Hauser@outlook.de>
# Contributor: Jean Lucas <jean@4ray.co>
pkgname=spotify-tui-git
-_pkgname=spotify-tui
-pkgver=0.16.0+r2+gdf3b6c3
+pkgver=0.25.0.r15.gc4dcf6b
pkgrel=1
-pkgdesc='Spotify client for the terminal written in Rust (git)'
+pkgdesc="Spotify client for the terminal written in Rust"
arch=(x86_64)
-url=https://github.com/Rigellute/spotify-tui
+url="https://github.com/Rigellute/spotify-tui"
license=(MIT)
-depends=(openssl libxcb)
-makedepends=(git cargo python)
+depends=(gcc-libs openssl)
+makedepends=(git cargo)
provides=(spotify-tui)
conflicts=(spotify-tui)
-source=(git+$url)
+source=("git+https://github.com/Rigellute/spotify-tui.git")
sha512sums=('SKIP')
pkgver() {
- cd $_pkgname
- git describe --tags | sed 's#v##;s#-#+#g;s#+#+r#'
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd $_pkgname
+ cd "${pkgname%-git}"
cargo build --locked --release
}
package() {
- cd $_pkgname
- install -D target/release/spt -t "$pkgdir"/usr/bin
- install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/$_pkgname
- install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$_pkgname
+ cd "${pkgname%-git}"
+ install -D target/release/spt -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}