summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-10-07 14:29:21 -0400
committerJean Lucas2019-10-07 14:29:21 -0400
commitf5a9be317fbcab1c751ee8c3414c2195ff5cfe6a (patch)
treea339c185dd4c796f6b014aa7b2ad2eff378d43b2
downloadaur-f5a9be317fbcab1c751ee8c3414c2195ff5cfe6a.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c642b9fb5231
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = spotify-tui-git
+ pkgdesc = Spotify for the terminal written in Rust (git)
+ pkgver = 0.4.0+r12+g4365b99
+ pkgrel = 1
+ url = https://github.com/Rigellute/spotify-tui
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cargo
+ depends = openssl
+ source = git+https://github.com/Rigellute/spotify-tui
+ sha512sums = SKIP
+
+pkgname = spotify-tui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76563016859a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=spotify-tui-git
+_pkgname=spotify-tui
+pkgver=0.4.0+r12+g4365b99
+pkgrel=1
+pkgdesc='Spotify for the terminal written in Rust (git)'
+arch=(i686 x86_64)
+url=https://github.com/Rigellute/spotify-tui
+license=(MIT)
+depends=(openssl)
+makedepends=(git cargo)
+source=(git+$url)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's#v##;s#-#+#g;s#+#+r#'
+}
+
+build() {
+ cd $_pkgname
+ cargo build --locked --release
+}
+
+package() {
+ cd $_pkgname
+ install -D target/release/spt -t "$pkgdir"/usr/bin
+ install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/$_pkgname
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$_pkgname
+}