summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario O.M2019-08-18 19:03:33 +0200
committerMario O.M2019-08-18 19:03:33 +0200
commit573583e63d5710b35482fa8849fcef10d6d2fec0 (patch)
treea1e74c17dfe0313f42e5a9654da76ba5453bd9d3
downloadaur-573583e63d5710b35482fa8849fcef10d6d2fec0.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD23
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27e2d2fd9a47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = spotify-videos
+ pkgdesc = Watch Youtube music videos for the currently playing Spotify songs
+ pkgver = 1.7.1
+ pkgrel = 1
+ url = https://github.com/marioortizmanero/spotify-music-videos
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = glib2
+ depends = python-gobject
+ depends = gtk3
+ depends = youtube-dl
+ depends = python-vlc
+ depends = python-lyricwikia
+ depends = python-dbus
+ depends = python-requests
+ depends = python-six
+ source = https://github.com/marioortizmanero/spotify-music-videos/archive/1.7.1.tar.gz
+ md5sums = cc380a63f20d61125923551cab31e96c
+
+pkgname = spotify-videos
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf1a6a4ddf39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mario O.M. <marioortizmanero@gmail.com>
+pkgname=spotify-videos
+pkgver=1.7.1
+pkgrel=1
+pkgdesc="Watch Youtube music videos for the currently playing Spotify songs"
+arch=("any")
+url="https://github.com/marioortizmanero/spotify-music-videos"
+license=("MIT")
+depends=("python" "glib2" "python-gobject" "gtk3" "youtube-dl" "python-vlc"
+ "python-lyricwikia" "python-dbus" "python-requests" "python-six")
+makedepends=("python-setuptools")
+source=("https://github.com/marioortizmanero/spotify-music-videos/archive/${pkgver}.tar.gz")
+md5sums=('cc380a63f20d61125923551cab31e96c')
+
+build() {
+ cd $srcdir/spotify-music-videos-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/spotify-music-videos-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}