summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkngfr2019-05-18 21:55:45 +0200
committerkngfr2019-05-18 22:01:13 +0200
commit33f3d55f3771158ef34c5a795aadd5ce377078c0 (patch)
tree1c1fa54d4fffb1fb58d927a7f72b6f5fffb0a562
downloadaur-33f3d55f3771158ef34c5a795aadd5ce377078c0.tar.gz
adding PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddf96ff54f8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = spotify_dl
+ pkgdesc = Downloads songs from your Spotify Playlist
+ pkgver = v3.r2.gb9d82fb
+ pkgrel = 1
+ url = https://github.com/SathyaBhat/spotify-dl
+ arch = any
+ license = MIT
+ depends = python-spotipy
+ depends = python-google-api-python-client
+ depends = youtube-dl
+ source = git+https://github.com/SathyaBhat/spotify-dl/
+ md5sums = SKIP
+
+pkgname = spotify_dl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a35ba99246ae
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/*
+src/*
+*.pkg.tar.xz
+spotify-dl/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b016de52a89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: kngfr <9bcfbc1ca230857ba09584697f20708a@kngfr.de>
+pkgname=spotify_dl
+_reponame=spotify-dl
+pkgver=v3.r2.gb9d82fb
+pkgrel=1
+epoch=
+pkgdesc="Downloads songs from your Spotify Playlist"
+arch=('any')
+url="https://github.com/SathyaBhat/spotify-dl"
+license=('MIT')
+depends=('python-spotipy' 'python-google-api-python-client' 'youtube-dl')
+source=("git+https://github.com/SathyaBhat/spotify-dl/")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_reponame"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$_reponame"
+ sed 's/^google-api-python-client==1.6.2$/google-api-python-client>=1.6.2/' -i requirements.txt
+ sed 's/^spotipy==2.3.8$/spotipy>=2.3.8/' -i requirements.txt
+ }
+
+build() {
+ cd "$srcdir/$_reponame"
+
+ python ./setup.py build
+}
+
+package() {
+ cd "$srcdir/$_reponame"
+
+ python ./setup.py install --root="$pkgdir"
+
+ install -D LICENSE "$pkgdir"/usr/share/licenses/"$_reponame"/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: