summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLetu Ren2022-04-20 11:47:57 +0800
committerLetu Ren2022-04-20 11:47:57 +0800
commitd8d87cd3adadcb38e662e6572928836745a4ed31 (patch)
tree9872b183bff9b0ac0a19633404b682bfb0d8a5bf
parentcc0a7baae9c811ecfec8978d70433ddbb3a5da1c (diff)
downloadaur-d8d87cd3adadcb38e662e6572928836745a4ed31.tar.gz
update to 8.3.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bef55101d84..5334d8d01ae4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spotify_dl
pkgdesc = Downloads songs from your Spotify Playlist
- pkgver = 8.2.0
+ pkgver = 8.3.0
pkgrel = 1
url = https://github.com/SathyaBhat/spotify-dl
arch = any
@@ -10,7 +10,7 @@ pkgbase = spotify_dl
depends = python-spotipy
depends = python-mutagen
depends = python-rich
- source = https://files.pythonhosted.org/packages/de/7a/ec1fc69d1a45bd2ec1a3fd0d46a14fa0adb3e9aa761269e478fac588a00f/spotify_dl-8.2.0.tar.gz
- sha256sums = fc2344c5c9f1f289a781487d4d6276915d632277cddffcd93660ff39d26cbbfb
+ source = https://files.pythonhosted.org/packages/source/s/spotify_dl/spotify_dl-8.3.0.tar.gz
+ sha256sums = 7817d710d30f3f646cd40d322ba6ff2f81d0a86c16d09cb825d316b7dfb78589
pkgname = spotify_dl
diff --git a/PKGBUILD b/PKGBUILD
index 1cad1207979e..e92b2b993e47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Letu Ren <fantasquex@gmail.com>
# Contributor: kngfr <9bcfbc1ca230857ba09584697f20708a@kngfr.de>
pkgname=spotify_dl
-_pkgname=spotify-dl
-pkgver=8.2.0
+pkgver=8.3.0
pkgrel=1
pkgdesc="Downloads songs from your Spotify Playlist"
arch=('any')
@@ -10,8 +9,8 @@ url="https://github.com/SathyaBhat/spotify-dl"
license=('MIT')
depends=('python-spotipy' 'python-google-api-python-client' 'youtube-dl')
depends=('python-sentry_sdk' 'yt-dlp' 'python-spotipy' 'python-mutagen' 'python-rich')
-source=("https://files.pythonhosted.org/packages/de/7a/ec1fc69d1a45bd2ec1a3fd0d46a14fa0adb3e9aa761269e478fac588a00f/spotify_dl-${pkgver}.tar.gz")
-sha256sums=('fc2344c5c9f1f289a781487d4d6276915d632277cddffcd93660ff39d26cbbfb')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('7817d710d30f3f646cd40d322ba6ff2f81d0a86c16d09cb825d316b7dfb78589')
build() {
cd "${pkgname}-${pkgver}"