summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Schäferdiek2017-03-26 14:27:50 +0200
committerAlexander Schäferdiek2017-03-26 14:27:50 +0200
commit10f27cfa1cec8c8297612f08a95f68943e0fc807 (patch)
treed3f8f253329af15b84a1c399f0780df1d161ebdf
downloadaur-10f27cfa1cec8c8297612f08a95f68943e0fc807.tar.gz
initial release
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD26
-rw-r--r--spotifyd@.service10
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c753e34c1adb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sun Mar 26 12:21:03 UTC 2017
+pkgbase = spotifyd
+ pkgdesc = A spotify playing daemon
+ pkgver = 30.3e5fce8
+ pkgrel = 1
+ url = https://github.com/Spotifyd/spotifyd
+ arch = x86_64
+ makedepends = git
+ makedepends = cargo
+ depends = pulseaudio
+ depends = flac
+ depends = libogg
+ depends = libpulse
+ depends = libsndfile
+ depends = libvorbis
+ conflicts = spotifyd-bin
+ source_x86_64 = spotifyd::git+https://github.com/Spotifyd/spotifyd
+ source_x86_64 = spotifyd@.service
+ md5sums_x86_64 = SKIP
+ md5sums_x86_64 = 230939d3dfe5986ed3587050955b2926
+
+pkgname = spotifyd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf218df07009
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=spotifyd
+pkgver=30.3e5fce8
+pkgrel=1
+arch=('x86_64')
+depends=('pulseaudio' 'flac' 'libogg' 'libpulse' 'libsndfile' 'libvorbis')
+makedepends=('git' 'cargo')
+conflicts=('spotifyd-bin')
+pkgdesc="A spotify playing daemon"
+url="https://github.com/Spotifyd/spotifyd"
+source_x86_64=("spotifyd::git+https://github.com/Spotifyd/spotifyd" "spotifyd@.service")
+md5sums_x86_64=('SKIP'
+ '230939d3dfe5986ed3587050955b2926')
+pkgver() {
+ cd $srcdir/spotifyd;
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd $srcdir/spotifyd;
+ cargo build --release --features "pulseaudio"
+}
+
+package() {
+ install -D -m 755 $srcdir/spotifyd/target/release/spotifyd "${pkgdir}/usr/bin/spotifyd"
+ install -D -m 644 "${srcdir}/spotifyd@.service" "${pkgdir}/usr/lib/systemd/system/spotifyd@.service"
+}
diff --git a/spotifyd@.service b/spotifyd@.service
new file mode 100644
index 000000000000..07e3a11f73b1
--- /dev/null
+++ b/spotifyd@.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=A spotify playing daemon for %i
+
+[Service]
+Type=simple
+User=%i
+ExecStart=/usr/bin/spotifyd --no-daemon
+
+[Install]
+WantedBy=multi-user.target