summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBert Peters2019-04-15 12:53:58 +0200
committerBert Peters2019-04-15 12:53:58 +0200
commit2872cf26ea03afa33bb173b653c66abe5526764b (patch)
treecc18a8de1d347fa2e2182ea7a66fbc6fdb4b7556
parent1fab919b9e91e3284bedd736d374a314be933888 (diff)
downloadaur-2872cf26ea03afa33bb173b653c66abe5526764b.tar.gz
Add a complete, "includes everyting" version.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c9ff750c38a..554ec334aeb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spotifyd
pkgdesc = A spotify playing daemon
pkgver = 0.2.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Spotifyd/spotifyd
arch = x86_64
arch = armv7h
@@ -30,3 +30,9 @@ pkgname = spotifyd-dbus-mpris
depends = dbus
conflicts = spotifyd
+pkgname = spotifyd-full
+ pkgdesc = A spotify playing daemon, with all Linux features enabled
+ depends = libpulse
+ depends = dbus
+ conflicts = spotifyd
+
diff --git a/PKGBUILD b/PKGBUILD
index 3248543c9960..8ad2b2ad9c75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Florian Klink <flokli@flokli.de>
pkgbase=spotifyd
-pkgname=('spotifyd' 'spotifyd-pulseaudio' 'spotifyd-dbus-mpris')
+pkgname=('spotifyd' 'spotifyd-pulseaudio' 'spotifyd-dbus-mpris' 'spotifyd-full')
pkgver=0.2.8
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'armv7h' 'aarch64')
license=('GPL3')
depends=('alsa-lib' 'libogg' 'gcc-libs')
@@ -14,6 +14,11 @@ pkgdesc="A spotify playing daemon"
url="https://github.com/Spotifyd/$pkgbase"
source=("$pkgbase-$pkgver.tar.gz::https://github.com/Spotifyd/$pkgbase/archive/v$pkgver.tar.gz")
sha256sums=('88d1e5ab60688b5505240b32a1a933e657cc239168057800c838f5fcd0e12c22')
+_features=(''
+ 'pulseaudio_backend'
+ 'dbus_mpris'
+ 'pulseaudio_backend,dbus_mpris,dbus_keyring'
+)
prepare() {
cd "$srcdir/spotifyd-$pkgver"
@@ -23,7 +28,7 @@ build() {
cd "$srcdir/spotifyd-$pkgver"
# Compile all variants. Compilation for later features can reuse
# previous build artifacts, so little overhead.
- for feature in "" pulseaudio_backend dbus_mpris; do
+ for feature in "${_features[@]}"; do
cargo build --release --locked --features "$feature"
done
}
@@ -52,3 +57,10 @@ package_spotifyd-dbus-mpris() {
pkgdesc="$pkgdesc, with D-Bus MPRIS"
_package_feature dbus_mpris
}
+
+package_spotifyd-full() {
+ depends=(libpulse dbus)
+ conflicts=(spotifyd)
+ pkgdesc="$pkgdesc, with all Linux features enabled"
+ _package_feature "${_features[3]}"
+}