summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Schäferdiek2017-06-10 02:53:24 +0200
committerAlexander Schäferdiek2017-06-10 02:53:24 +0200
commit83ba7e5ac22d0afba7a3c0d30a5518680e874ff5 (patch)
treec2aaec5a4a18bb15a865f88940e12f99d7927d80
parentb21ddc8dfee25a3764e89b6f632b359e18b97547 (diff)
downloadaur-83ba7e5ac22d0afba7a3c0d30a5518680e874ff5.tar.gz
update to latest release, added x86 again
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
-rw-r--r--spotifyd.service11
-rw-r--r--spotifyd@.service10
4 files changed, 33 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81316bcbc86d..d4dff112dbd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,20 @@
# Generated by mksrcinfo v8
-# Sun Mar 26 11:45:52 UTC 2017
+# Sat Jun 10 00:48:12 UTC 2017
pkgbase = spotifyd-bin
pkgdesc = A spotify playing daemon
- pkgver = 8d1809f9710e3af4cda7
- pkgrel = 1
+ pkgver = ad661221349c1b7fd273
+ pkgrel = 2
url = https://github.com/Spotifyd/spotifyd
arch = armv7h
- source_armv7h = https://github.com/Spotifyd/spotifyd/releases/download/untagged-8d1809f9710e3af4cda7/spotifyd-2017-02-18-armv7.zip
- source_armv7h = spotifyd@.service
- md5sums_armv7h = 9adadc8a9e8aeee88d017a00db3f1280
- md5sums_armv7h = 230939d3dfe5986ed3587050955b2926
+ arch = x86_64
+ source_armv7h = https://github.com/Spotifyd/spotifyd/releases/download/untagged-ad661221349c1b7fd273/spotifyd-2017-06-04-armv7.zip
+ source_armv7h = spotifyd.service
+ md5sums_armv7h = cc27b775bf74b7bcff5d7f5b866afad7
+ md5sums_armv7h = eb95cf4735565e0c596d7e0118fd1e6e
+ source_x86_64 = https://github.com/Spotifyd/spotifyd/releases/download/untagged-ad661221349c1b7fd273/spotifyd-2017-06-04-amd64.zip
+ source_x86_64 = spotifyd.service
+ md5sums_x86_64 = 34e9e86b61283db1169c854a3eb07208
+ md5sums_x86_64 = eb95cf4735565e0c596d7e0118fd1e6e
pkgname = spotifyd-bin
diff --git a/PKGBUILD b/PKGBUILD
index c7e4539db98b..a6e103883967 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
pkgname=spotifyd-bin
-pkgver=8d1809f9710e3af4cda7
-pkgrel=1
-#arch=('armv7h' 'x86_64')
-arch=('armv7h')
+pkgver=ad661221349c1b7fd273
+pkgrel=2
+arch=('armv7h' 'x86_64')
pkgdesc="A spotify playing daemon"
url="https://github.com/Spotifyd/spotifyd"
-#source_x86_64=("https://github.com/Spotifyd/spotifyd/releases/download/untagged-${pkgver}/spotifyd-2017-02-18-amd64.zip" "spotifyd@.service")
-#md5sums_x86_64=('61dc585dd3c4581900e7a8191822c791' 'deb315535d8d0c00a4e5698057e4e546')
-md5sums_armv7h=('9adadc8a9e8aeee88d017a00db3f1280'
- '230939d3dfe5986ed3587050955b2926')
-source_armv7h=("https://github.com/Spotifyd/spotifyd/releases/download/untagged-${pkgver}/spotifyd-2017-02-18-armv7.zip" "spotifyd@.service")
+source_x86_64=("https://github.com/Spotifyd/spotifyd/releases/download/untagged-${pkgver}/spotifyd-2017-06-04-amd64.zip" "spotifyd.service")
+md5sums_armv7h=('cc27b775bf74b7bcff5d7f5b866afad7'
+ 'eb95cf4735565e0c596d7e0118fd1e6e')
+md5sums_x86_64=('34e9e86b61283db1169c854a3eb07208'
+ 'eb95cf4735565e0c596d7e0118fd1e6e')
+source_armv7h=("https://github.com/Spotifyd/spotifyd/releases/download/untagged-${pkgver}/spotifyd-2017-06-04-armv7.zip" "spotifyd.service")
package() {
install -D -m 755 spotifyd "${pkgdir}/usr/bin/spotifyd"
- install -D -m644 "${srcdir}/spotifyd@.service" "${pkgdir}/usr/lib/systemd/system/spotifyd@.service"
+ install -D -m644 "${srcdir}/spotifyd.service" "${pkgdir}/usr/lib/systemd/user/spotifyd.service"
}
diff --git a/spotifyd.service b/spotifyd.service
new file mode 100644
index 000000000000..df35ce64801d
--- /dev/null
+++ b/spotifyd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=A spotify playing daemon
+Documentation=https://github.com/Spotifyd/spotifyd
+
+[Service]
+ExecStart=/usr/bin/spotifyd --no-daemon
+Restart=always
+RestartSec=12
+
+[Install]
+WantedBy=default.target \ No newline at end of file
diff --git a/spotifyd@.service b/spotifyd@.service
deleted file mode 100644
index 07e3a11f73b1..000000000000
--- a/spotifyd@.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=A spotify playing daemon for %i
-
-[Service]
-Type=simple
-User=%i
-ExecStart=/usr/bin/spotifyd --no-daemon
-
-[Install]
-WantedBy=multi-user.target