summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVarakh2019-11-27 18:07:01 +0100
committerVarakh2019-11-27 18:07:01 +0100
commitc076f244b81d6289e5560a386ea9bdd6e840e352 (patch)
treed5cccbf31e88ed8623b6b7668780cb0bad78d7f7
downloadaur-c076f244b81d6289e5560a386ea9bdd6e840e352.tar.gz
Add spotifyd-bin full variant, initial version 0.2.20
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD20
-rw-r--r--spotifyd.service11
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd7048fd47cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = spotifyd-bin-full
+ pkgdesc = A spotify playing daemon - full distribution
+ pkgver = 0.2.20
+ pkgrel = 1
+ url = https://github.com/Spotifyd/spotifyd
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ depends = libpulse
+ depends = dbus
+ provides = spotifyd
+ conflicts = spotifyd
+ source = spotifyd-bin-full-0.2.20.tar.gz::https://github.com/Spotifyd/spotifyd/releases/download/v0.2.20/spotifyd-linux-full.tar.gz
+ source = spotifyd.service
+ sha256sums = e53a984a1280424e4679cf531b3eb896e1243f5cd3042df602ffe0ffcc3f1f4c
+ sha256sums = 67bce68cfad74bfccad4b471045d3c5d5fb0f693545f3ef12511d171ea41a5e4
+
+pkgname = spotifyd-bin-full
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b343a5c33bbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Varakh <varakh@varakh.de>
+
+pkgname=('spotifyd-bin-full')
+pkgver=0.2.20
+pkgrel=1
+conflicts=('spotifyd')
+provides=('spotifyd')
+depends=('libpulse' 'dbus')
+arch=('x86_64' 'armv6h' 'armv7h' 'aarch64')
+license=('GPL3')
+pkgdesc="A spotify playing daemon - full distribution"
+url="https://github.com/Spotifyd/spotifyd"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Spotifyd/spotifyd/releases/download/v$pkgver/spotifyd-linux-full.tar.gz" "spotifyd.service")
+sha256sums=('e53a984a1280424e4679cf531b3eb896e1243f5cd3042df602ffe0ffcc3f1f4c'
+ '67bce68cfad74bfccad4b471045d3c5d5fb0f693545f3ef12511d171ea41a5e4')
+
+package() {
+ install -D -m 755 spotifyd "${pkgdir}/usr/bin/spotifyd"
+ install -D -m644 "${srcdir}/spotifyd.service" "${pkgdir}/usr/lib/systemd/user/spotifyd.service"
+}
diff --git a/spotifyd.service b/spotifyd.service
new file mode 100644
index 000000000000..df35ce64801d
--- /dev/null
+++ b/spotifyd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=A spotify playing daemon
+Documentation=https://github.com/Spotifyd/spotifyd
+
+[Service]
+ExecStart=/usr/bin/spotifyd --no-daemon
+Restart=always
+RestartSec=12
+
+[Install]
+WantedBy=default.target \ No newline at end of file