summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Schäferdiek2017-07-26 13:12:05 +0200
committerAlexander Schäferdiek2017-07-26 13:12:05 +0200
commitc749f00c9bc99f0117e364ca9e9a4d2bd9871d8c (patch)
tree83d0452468e1dd4915a7e81b8c98af97160f8462
downloadaur-c749f00c9bc99f0117e364ca9e9a4d2bd9871d8c.tar.gz
git version init
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD29
-rw-r--r--spotifyd.service11
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc1a596f447c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Wed Jul 26 11:11:38 UTC 2017
+pkgbase = spotifyd-git
+ pkgdesc = A spotify playing daemon
+ pkgver = 0.1.1.1.g60f111f
+ pkgrel = 1
+ url = https://github.com/Spotifyd/spotifyd
+ arch = x86_64
+ arch = armv7h
+ makedepends = git
+ makedepends = cargo
+ depends = pulseaudio
+ depends = flac
+ depends = libogg
+ depends = libpulse
+ depends = libsndfile
+ depends = libvorbis
+ conflicts = spotifyd-bin
+ source = spotifyd::git+https://github.com/Spotifyd/spotifyd
+ source = spotifyd.service
+ sha256sums = SKIP
+ sha256sums = 67bce68cfad74bfccad4b471045d3c5d5fb0f693545f3ef12511d171ea41a5e4
+
+pkgname = spotifyd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1dc30b2605d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Alexander Schäferdiek <alexander@schaeferdiek.eu>
+# Maintainer: Florian Klink <flokli@flokli.de>
+
+pkgname=spotifyd-git
+pkgver=0.1.1.1.g60f111f
+pkgrel=1
+arch=('x86_64' 'armv7h')
+depends=('pulseaudio' 'flac' 'libogg' 'libpulse' 'libsndfile' 'libvorbis')
+makedepends=('git' 'cargo')
+conflicts=('spotifyd-bin')
+pkgdesc="A spotify playing daemon"
+url="https://github.com/Spotifyd/spotifyd"
+source=("spotifyd::git+https://github.com/Spotifyd/spotifyd" "spotifyd.service")
+sha256sums=('SKIP'
+ '67bce68cfad74bfccad4b471045d3c5d5fb0f693545f3ef12511d171ea41a5e4')
+pkgver() {
+ cd $srcdir/spotifyd;
+ git describe --tags --match 'v*' | sed 's/^v//;s/-/./g'
+}
+
+build() {
+ cd $srcdir/spotifyd;
+ cargo build --release --features "pulseaudio_backend"
+}
+
+package() {
+ install -D -m 755 $srcdir/spotifyd/target/release/spotifyd "${pkgdir}/usr/bin/spotifyd"
+ install -D -m 644 "${srcdir}/spotifyd.service" "${pkgdir}/usr/lib/systemd/user/spotifyd.service"
+}
diff --git a/spotifyd.service b/spotifyd.service
new file mode 100644
index 000000000000..df35ce64801d
--- /dev/null
+++ b/spotifyd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=A spotify playing daemon
+Documentation=https://github.com/Spotifyd/spotifyd
+
+[Service]
+ExecStart=/usr/bin/spotifyd --no-daemon
+Restart=always
+RestartSec=12
+
+[Install]
+WantedBy=default.target \ No newline at end of file