summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabrizio Pietrucci2020-10-26 13:08:24 +0100
committerFabrizio Pietrucci2020-10-26 13:08:24 +0100
commitdd0a8a91ec0ea4d68c3a27c9fcac4d8604759de8 (patch)
tree2ad8db3e3c96769f7bcb5cd663c6bedf7a5703a1
downloadaur-dd0a8a91ec0ea4d68c3a27c9fcac4d8604759de8.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0afe3816ffd3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = spotitube-bin
+ pkgdesc = Synchronize your Spotify collections downloading from external providers
+ pkgver = 29
+ pkgrel = 1
+ url = https://github.com/streambinder/spotitube
+ arch = x86_64
+ license = GPL3
+ depends = youtube-dl
+ depends = ffmpeg
+ depends = xdg-utils
+ provides = spotitube
+ source = https://github.com/streambinder/spotitube/releases/download/v29/spotitube-v29.bin
+ source = https://raw.githubusercontent.com/streambinder/spotitube/master/LICENSE
+ sha256sums = 4a0d034db781a9ce0038947fbef2a5b313604c13dc2cfc2e3184cac0f0c9915d
+ sha256sums = SKIP
+
+pkgname = spotitube-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a980af00afe5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5aa9164a921f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Mantainer: Fabrizio Pietrucci <bamlessnty5@gmail.com>
+
+_pkgname=spotitube
+pkgname="${_pkgname}-bin"
+provides=(spotitube)
+pkgver=29
+pkgrel=1
+pkgdesc="Synchronize your Spotify collections downloading from external providers"
+arch=('x86_64')
+url="https://github.com/streambinder/spotitube"
+license=('GPL3')
+depends=('youtube-dl' 'ffmpeg' 'xdg-utils')
+
+source=("https://github.com/streambinder/spotitube/releases/download/v${pkgver}/${_pkgname}-v${pkgver}.bin"
+ "https://raw.githubusercontent.com/streambinder/spotitube/master/LICENSE")
+
+sha256sums=("4a0d034db781a9ce0038947fbef2a5b313604c13dc2cfc2e3184cac0f0c9915d"
+ "SKIP")
+
+package() {
+ cd ${srcdir}
+ install -Dm755 ${_pkgname}-v${pkgver}.bin ${pkgdir}/usr/bin/${_pkgname}
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE
+}