summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElias2020-12-24 19:31:11 +0100
committerElias2020-12-24 19:31:11 +0100
commitcf5eaeb5f32e68793d907f5272b5328df4ffe858 (patch)
treedcdfe8435e7db8508a4e8a8ccb37801349e18800
parentdd40488ef8aad8295e4087cbaa76b7ac078667bf (diff)
downloadaur-cf5eaeb5f32e68793d907f5272b5328df4ffe858.tar.gz
clean optional deps & install license
-rw-r--r--.SRCINFO6
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD13
3 files changed, 31 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8434bd795d3..ac42b882d389 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spotrec
pkgdesc = Spotify desktop client recorder for PulseAudio
pkgver = 0.13.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Bleuzen/SpotRec
arch = any
license = mit
@@ -11,10 +11,10 @@ pkgbase = spotrec
depends = gawk
depends = bash
optdepends = spotify
- optdepends = audacity
- optdepends = kid3
source = spotrec::https://github.com/Bleuzen/SpotRec/releases/download/v0.13.0/spotrec.py
+ source = https://raw.githubusercontent.com/Bleuzen/SpotRec/master/LICENSE
md5sums = ef9f6f30245bdcd9f2f499643aeb9554
+ md5sums = SKIP
pkgname = spotrec
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3b892f419ba3
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 Bleuzen
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 7cb40e96c326..0e35af74a0d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
pkgname=spotrec
pkgver=0.13.0
-pkgrel=1
+pkgrel=2
pkgdesc="Spotify desktop client recorder for PulseAudio"
arch=('any')
url="https://github.com/Bleuzen/SpotRec"
license=('mit')
depends=('python' 'python-dbus' 'ffmpeg' 'gawk' 'bash')
-optdepends=('spotify'
- 'audacity'
- 'kid3')
-source=("spotrec::${url}/releases/download/v${pkgver}/${pkgname}.py")
-md5sums=('ef9f6f30245bdcd9f2f499643aeb9554')
+optdepends=('spotify')
+source=("spotrec::${url}/releases/download/v${pkgver}/${pkgname}.py"
+ "https://raw.githubusercontent.com/Bleuzen/SpotRec/master/LICENSE")
+md5sums=('ef9f6f30245bdcd9f2f499643aeb9554'
+ 'SKIP')
package() {
mkdir -p "$pkgdir"/usr/bin/
install -D ${pkgname} "$pkgdir"/usr/bin/
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}