summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKingkor Roy Tirtho2022-01-15 17:49:05 +0600
committerKingkor Roy Tirtho2022-01-15 17:49:05 +0600
commiteec4bf253918c3c1d56bdcea513fc00bdf6bb167 (patch)
tree3644229d17e1d1e4e6c6874a1c79d68941d93243
downloadaur-eec4bf253918c3c1d56bdcea513fc00bdf6bb167.tar.gz
version-1-release-srcinfo-update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD36
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c3375948014
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = spotube
+ pkgdesc = A lightweight free Spotify desktop-client which handles playback manually, streams music using Youtube & no Spotify premium account is needed
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/KRTirtho/spotube/
+ arch = x86_64
+ license = BSD 4-Clause
+ source = https://github.com/KRTirtho/spotube/releases/download/v1.0.1/Spotube-linux-x86_64.tar.xz
+ md5sums = 44f79f93ddaf6f0c4e7d133d2fe34bde
+
+pkgname = spotube
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..448fc3d9e2c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Kingkor Roy Tirtho <krtirho@gmail.com>
+pkgname=spotube
+pkgver=1.0.1
+pkgrel=1
+epoch=
+pkgdesc="A lightweight free Spotify desktop-client which handles playback manually, streams music using Youtube & no Spotify premium account is needed"
+arch=(x86_64)
+url="https://github.com/KRTirtho/spotube/"
+license=('BSD 4-Clause')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/KRTirtho/spotube/releases/download/v${pkgver}/Spotube-linux-x86_64.tar.xz")
+noextract=()
+md5sums=(44f79f93ddaf6f0c4e7d133d2fe34bde)
+validpgpkeys=()
+
+package(){
+ install -dm755 "${pkgdir}/usr/share/icons/${pkgname}"
+ install -dm755 "${pkgdir}/usr/share/applications"
+ install -dm755 "${pkgdir}/usr/share/${pkgname}"
+ install -dm755 "${pkgdir}/usr/bin"
+ cp -ra ./ "${pkgdir}/usr/share/${pkgname}"
+ cp ./spotube.desktop "${pkgdir}/usr/share/applications"
+ cp ./spotube-logo.png "${pkgdir}/usr/share/icons/${pkgname}"
+ ln -s "/usr/share/${pkgname}/spotube" "${pkgdir}/usr/bin/${pkgname}"
+}