summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKingkor Roy Tirtho2022-02-06 10:09:47 +0600
committerKingkor Roy Tirtho2022-02-06 10:09:47 +0600
commit1298b601db9c18ad20f347aef376f4b350e6e6c0 (patch)
tree3df79b6b34e2fdc4324711835c9f465c9bebb1de
downloadaur-1298b601db9c18ad20f347aef376f4b350e6e6c0.tar.gz
Reupload of the v1.1.0 of spotube package as spotube-bin
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD36
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9739814392f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = spotube-bin
+ pkgdesc = A lightweight free Spotify desktop-client which handles playback manually, streams music using Youtube & no Spotify premium account is needed
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/KRTirtho/spotube/
+ arch = x86_64
+ license = BSD-4-Clause
+ depends = libkeybinder3
+ source = https://github.com/KRTirtho/spotube/releases/download/v1.1.0/Spotube-linux-x86_64.tar.xz
+ md5sums = 0db87627ddf753bc7f09ebbb282184ee
+
+pkgname = spotube-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee7c4a75e8a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Kingkor Roy Tirtho <krtirho@gmail.com>
+pkgname=spotube-bin
+pkgver=1.1.0
+pkgrel=1
+epoch=
+pkgdesc="A lightweight free Spotify desktop-client which handles playback manually, streams music using Youtube & no Spotify premium account is needed"
+arch=(x86_64)
+url="https://github.com/KRTirtho/spotube/"
+license=('BSD-4-Clause')
+groups=()
+depends=('libkeybinder3')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/KRTirtho/spotube/releases/download/v${pkgver}/Spotube-linux-x86_64.tar.xz")
+noextract=()
+md5sums=(0db87627ddf753bc7f09ebbb282184ee)
+validpgpkeys=()
+
+package(){
+ install -dm755 "${pkgdir}/usr/share/icons/${pkgname}"
+ install -dm755 "${pkgdir}/usr/share/applications"
+ install -dm755 "${pkgdir}/usr/share/${pkgname}"
+ install -dm755 "${pkgdir}/usr/bin"
+ cp -ra ./ "${pkgdir}/usr/share/${pkgname}"
+ cp ./spotube.desktop "${pkgdir}/usr/share/applications"
+ cp ./spotube-logo.png "${pkgdir}/usr/share/icons/${pkgname}"
+ ln -s "/usr/share/${pkgname}/spotube" "${pkgdir}/usr/bin/${pkgname}"
+}