summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneuralstring2023-08-22 10:58:21 +0330
committerneuralstring2023-08-22 10:58:21 +0330
commit64ed3b7142efdbc83960a6a9adb0b55d8d15a64e (patch)
treeabbc27fd5380507fc627225746e1996ff1093e60
downloadaur-64ed3b7142efdbc83960a6a9adb0b55d8d15a64e.tar.gz
Init
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc172daa532d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Artimes Phoenix <artimesphoenix@gmail.com>
+
+pkgname=spotx-git
+pkgver=r12.bd90536
+pkgrel=1
+pkgdesc="SpotX Bash Script | Block all audio, banner & video ads | Block logging"
+arch=('any')
+url="https://github.com/jetfir3/SpotX-Bash"
+license=('GPL')
+makedepends=('git')
+provides=("${pkgname}")
+source=("${pkgname}::git+https://github.com/jetfir3/SpotX-Bash.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm755 spotx.sh "${pkgdir}/usr/bin/spotx"
+}