summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2024-03-16 20:15:36 +0100
committerMichal Wojdyla2024-03-16 20:15:36 +0100
commit5322a294e113c9b0549f98bab607ca2de94a6335 (patch)
tree2a02df74118635f46a71f6d55233ffac9120c448
parent6ba504bd087b8fb6a39ae1eab80691f29ab6a18c (diff)
downloadaur-5322a294e113c9b0549f98bab607ca2de94a6335.tar.gz
Packaging fixes
Declare all git submodules in source=() array. Update dependencies. Remove unneeded install hook for gtk-update-icon-cache.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
-rw-r--r--springlobby.install11
3 files changed, 12 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf4dfbd05d8c..181538cdf6f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = springlobby-git
pkgdesc = A free cross-platform lobby client for the Spring RTS project, development version.
pkgver = 0.274.4.g290f1fa73
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/springlobby/springlobby/wiki
- install = springlobby.install
arch = i686
arch = x86_64
license = GPL2
@@ -11,14 +10,16 @@ pkgbase = springlobby-git
makedepends = cmake
makedepends = boost
depends = wxwidgets-gtk3
- depends = boost-libs
depends = libnotify
depends = curl
depends = hicolor-icon-theme
depends = alure
+ depends = minizip
provides = springlobby
conflicts = springlobby
source = git+https://github.com/springlobby/springlobby.git
+ source = git+https://github.com/spring/pr-downloader.git
+ md5sums = SKIP
md5sums = SKIP
pkgname = springlobby-git
diff --git a/PKGBUILD b/PKGBUILD
index fd5a521a7df8..844f3c068acb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
+# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
# Contributor: cleanrock (AT gmail DOT com)
# Contributor: Erdbeerkaese (erdbeerkaese AT gawab DOT com)
# Contributor: DuGi <dugi@irc.pl>
pkgname=springlobby-git
pkgver=0.274.4.g290f1fa73
-pkgrel=1
+pkgrel=2
pkgdesc="A free cross-platform lobby client for the Spring RTS project, development version."
arch=('i686' 'x86_64')
url="https://github.com/springlobby/springlobby/wiki"
license=('GPL2')
-depends=('wxwidgets-gtk3' 'boost-libs' 'libnotify' 'curl' 'hicolor-icon-theme' 'alure')
+depends=('wxwidgets-gtk3' 'libnotify' 'curl' 'hicolor-icon-theme' 'alure' 'minizip')
optdepends=()
makedepends=('git' 'cmake' 'boost')
conflicts=('springlobby')
provides=('springlobby')
-install=springlobby.install
-source=('git+https://github.com/springlobby/springlobby.git')
+source=('git+https://github.com/springlobby/springlobby.git'
+ 'git+https://github.com/spring/pr-downloader.git')
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP' 'SKIP')
# options=('!strip' 'debug' '!buildflags')
_gitname="springlobby"
@@ -31,7 +32,8 @@ pkgver() {
prepare() {
cd "$srcdir/$_gitname"
git submodule init
- git submodule update
+ git config submodule.src/downloader/lib.url "${srcdir}/pr-downloader"
+ git submodule--helper update
}
build() {
diff --git a/springlobby.install b/springlobby.install
deleted file mode 100644
index 1a05f573e594..000000000000
--- a/springlobby.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}