summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-15 15:47:36 +0300
committerDimitris Kiziridis2020-05-15 15:47:36 +0300
commit3c6524a8e4f1597116d6c2b172f9a90a5644a998 (patch)
tree0c4edcd3c4bab84d0430968ef6982c1f6dfc5d57
parenta9bc94f028e6435a4b886b4cf2bbd29f09cc5d5d (diff)
downloadaur-3c6524a8e4f1597116d6c2b172f9a90a5644a998.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2e4c6865e70..6ef2ec35e46f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,17 +6,19 @@ pkgbase = spriteilluminator
install = spriteilluminator.install
arch = x86_64
license = custom:spriteilluminator
- depends = shared-mime-info
depends = hicolor-icon-theme
depends = desktop-file-utils
depends = grantlee
depends = gcc-libs-multilib
depends = qt5-svg
- depends = qt5-declarative
depends = qt5-imageformats
depends = qt5-quickcontrols
- source = https://www.codeandweb.com/download/spriteilluminator/1.5.4/SpriteIlluminator-1.5.4-ubuntu64.deb
- md5sums = b27053836c535d8ebd2daf83881e197e
+ depends = qt5-wayland
+ depends = qt5-quickcontrols2
+ depends = qt5-xmlpatterns
+ options = !strip
+ source = spriteilluminator-1.5.4.deb::https://www.codeandweb.com/download/spriteilluminator/1.5.4/SpriteIlluminator-1.5.4-ubuntu64.deb
+ sha256sums = 0498c4d058d30ec42b241b6a86c53e9ecf183bd80cb64b691e54b347ea7f4156
pkgname = spriteilluminator
diff --git a/PKGBUILD b/PKGBUILD
index 7856cbb67f1f..3b8dc84ebd52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,24 +11,22 @@ pkgver=1.5.4
pkgrel=2
pkgdesc="Tool for creating Normal Maps, also known as Dot3 Bump Maps, which generate a 2.5D effect in different game engines including Cocos2D-X"
arch=('x86_64')
-url="http://www.codeandweb.com/$pkgname"
+url="http://www.codeandweb.com/spriteilluminator"
license=("custom:$pkgname")
install="$pkgname.install"
-depends=('shared-mime-info'
- 'hicolor-icon-theme'
+depends=('hicolor-icon-theme'
'desktop-file-utils'
'grantlee'
- 'gcc-libs-multilib'
+ 'gcc-libs-multilib'
'qt5-svg'
- 'qt5-declarative'
'qt5-imageformats'
- 'qt5-quickcontrols')
-source=("https://www.codeandweb.com/download/$pkgname/${pkgver}/SpriteIlluminator-${pkgver}-ubuntu64.deb")
-md5sums=('b27053836c535d8ebd2daf83881e197e')
-
-prepare() {
- ar -x "SpriteIlluminator-${pkgver}-ubuntu64.deb"
-}
+ 'qt5-quickcontrols'
+ 'qt5-wayland'
+ 'qt5-quickcontrols2'
+ 'qt5-xmlpatterns')
+options=('!strip')
+source=("${pkgname}-${pkgver}.deb::https://www.codeandweb.com/download/$pkgname/${pkgver}/SpriteIlluminator-${pkgver}-ubuntu64.deb")
+sha256sums=('0498c4d058d30ec42b241b6a86c53e9ecf183bd80cb64b691e54b347ea7f4156')
package() {
cd "${srcdir}"