summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-04 08:57:37 +0300
committerDimitris Kiziridis2020-04-04 08:57:37 +0300
commita9bc94f028e6435a4b886b4cf2bbd29f09cc5d5d (patch)
tree1f7ab5c31bb8ed2e56c219ccc18c70800888842f
parent6f6202811874265a8b6909a7b17e5ee7f477ced8 (diff)
downloadaur-a9bc94f028e6435a4b886b4cf2bbd29f09cc5d5d.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD48
2 files changed, 19 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f57fc1e6396..e2e4c6865e70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spriteilluminator
pkgdesc = Tool for creating Normal Maps, also known as Dot3 Bump Maps, which generate a 2.5D effect in different game engines including Cocos2D-X
pkgver = 1.5.4
- pkgrel = 1
+ pkgrel = 2
url = http://www.codeandweb.com/spriteilluminator
install = spriteilluminator.install
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = spriteilluminator
depends = qt5-imageformats
depends = qt5-quickcontrols
source = https://www.codeandweb.com/download/spriteilluminator/1.5.4/SpriteIlluminator-1.5.4-ubuntu64.deb
- sha256sums = 0498c4d058d30ec42b241b6a86c53e9ecf183bd80cb64b691e54b347ea7f4156
+ md5sums = b27053836c535d8ebd2daf83881e197e
pkgname = spriteilluminator
diff --git a/PKGBUILD b/PKGBUILD
index aa40ce2322a5..7856cbb67f1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,45 +8,31 @@
pkgname=spriteilluminator
pkgver=1.5.4
-pkgrel=1
+pkgrel=2
pkgdesc="Tool for creating Normal Maps, also known as Dot3 Bump Maps, which generate a 2.5D effect in different game engines including Cocos2D-X"
arch=('x86_64')
url="http://www.codeandweb.com/$pkgname"
license=("custom:$pkgname")
install="$pkgname.install"
-depends=('shared-mime-info' 'hicolor-icon-theme' 'desktop-file-utils' 'grantlee'
- 'gcc-libs-multilib' 'qt5-svg' 'qt5-declarative' 'qt5-imageformats'
+depends=('shared-mime-info'
+ 'hicolor-icon-theme'
+ 'desktop-file-utils'
+ 'grantlee'
+ 'gcc-libs-multilib'
+ 'qt5-svg'
+ 'qt5-declarative'
+ 'qt5-imageformats'
'qt5-quickcontrols')
source=("https://www.codeandweb.com/download/$pkgname/${pkgver}/SpriteIlluminator-${pkgver}-ubuntu64.deb")
-sha256sums=("0498c4d058d30ec42b241b6a86c53e9ecf183bd80cb64b691e54b347ea7f4156")
+md5sums=('b27053836c535d8ebd2daf83881e197e')
-build() {
- ar -x "SpriteIlluminator-${pkgver}-ubuntu64.deb"
+prepare() {
+ ar -x "SpriteIlluminator-${pkgver}-ubuntu64.deb"
}
package() {
- cd ${srcdir}/
-
- # Extract to the $pkgdir.
- tar xJf data.tar.xz -C "${pkgdir}/"
-
- # Enter $pkgdir.
- cd ${pkgdir}/usr/lib/$pkgname/
-
- # FIXME: There's a symbol in the spriteilluminator Qt library that's not in
- # the official repository. Double check if we can use the Qt library from
- # the official repository on future versions
-
- ## Delete all the extra lib folders.
- #rm -rf generic/ grantlee/ iconengines/ imageformats/ platforminputcontexts/ platforms/ \
- # QtGraphicalEffects/ QtQml/ QtQuick/ QtQuick.2/ xcbglintegrations/
-
- ## Delete the useless lib files.
- #rm -rf libGrantlee* libicudata* libicui18n* libicuuc* libQt5*
-
- ## Get rid of the Qt configuration that messes up LD_LIBRARY_PATH.
- #rm -rf qt.conf
-
- install -Dm644 "${pkgdir}/usr/share/$pkgname/documents/LicenseAgreement.txt" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LicenseAgreement.txt"
-}
+ cd "${srcdir}"
+ tar xJf data.tar.xz -C "${pkgdir}"
+ install -Dm644 "${pkgdir}/usr/share/$pkgname/documents/LicenseAgreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file