summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Morris2020-10-19 16:48:38 -0700
committerKevin Morris2020-10-19 16:48:38 -0700
commitce84d6beb63faaf12c58d48b25ab5768ab8577dd (patch)
tree3b6369562f2ec5554bdd64b2d60cb4da136d4152
parent125cc2893d15e0efe09b93c57821953a157745fd (diff)
downloadaur-ce84d6beb63faaf12c58d48b25ab5768ab8577dd.tar.gz
Fetch $release tag archive from upstream
Signed-off-by: Kevin Morris <kevr@0cost.org>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85ec3e6ca647..fec6ab199069 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,8 +9,8 @@ pkgbase = sprunge
license = GPL2
depends = python
optdepends = xclip: default --clipboard-command.
- source = sprunge
- sha256sums = 098b1a2e84c4251d5bd68d017597bb483dacd8565e0f28042c90ae052f1d0fb0
+ source = https://www.github.com/kevr/sprunge/archive/0.3.tar.gz
+ sha256sums = 85844eccc7d1a6e22b11decb613305a68362d373258d0801d0b186cb3d9b60ab
pkgname = sprunge
diff --git a/PKGBUILD b/PKGBUILD
index 4f4189b0e174..4c47b2cbd65d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
pkgname='sprunge'
-pkgver='0.3.0'
+release='0.3'
+pkgver="${release}.0"
pkgrel=1
pkgdesc='Upload data to sprunge.us via stdin'
license=('GPL2')
@@ -8,13 +9,13 @@ url='https://github.com/kevr/sprunge'
arch=('i686' 'x86_64' 'armv6h')
depends=('python')
optdepends=('xclip: default --clipboard-command.')
-source=('sprunge')
+source=("https://www.github.com/kevr/sprunge/archive/${release}.tar.gz")
sha256sums=(
- '098b1a2e84c4251d5bd68d017597bb483dacd8565e0f28042c90ae052f1d0fb0'
+ '85844eccc7d1a6e22b11decb613305a68362d373258d0801d0b186cb3d9b60ab'
)
package()
{
- install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/${pkgname}-${release}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}