summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTab Fitts2018-04-24 16:05:05 -0700
committerTab Fitts2018-04-24 16:05:05 -0700
commit3592d241067947de3137aae70af1d78b80d62291 (patch)
tree668134036b3ea7a5174cb914e3e5b32302b096f9
downloadaur-3592d241067947de3137aae70af1d78b80d62291.tar.gz
Initial commit to aur
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD68
-rw-r--r--sprycloud-client.install19
-rw-r--r--sprycloud-client.service12
5 files changed, 131 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14f6d778d8dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = sprycloud-client-git
+ pkgdesc = spryCloud client for Linux
+ pkgver = spry_v2.5.0
+ pkgrel = 2
+ url = https://www.spryservers.net/
+ install = sprycloud-client.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = qtkeychain
+ depends = qt5-webkit
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ provides = mirall
+ provides = mirall-git
+ provides = sprycloud-client
+ conflicts = sprycloud-client
+ options = !strip
+ backup = etc/spryCloud/sync-exclude.lst
+ source = sprycloud-client::git+https://github.com/SpryServers/sprycloud-client-next.git
+ source = sprycloud-client.service
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = sprycloud-client-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c380b3ada81d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+sprycloud-client/
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b01406d5a79e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Tab Fitts <tfitts at spryservers dot net>
+# Git: https://github.com/SpryServers/sprycloud-client-arch
+
+# Uncomment, if you want tha last release
+_version=spry_v2.5.0
+pkgname=sprycloud-client-git
+_name=${pkgname/\-git/}
+pkgver=spry_v2.5.0
+pkgrel=2
+pkgdesc="spryCloud client for Linux"
+arch=('i686' 'x86_64')
+url="https://www.spryservers.net/"
+license=('GPL2')
+depends=('qtkeychain' 'qt5-webkit' 'hicolor-icon-theme' 'xdg-utils')
+optdepends=()
+makedepends=('cmake' 'qt5-tools')
+provides=('mirall' 'mirall-git' 'sprycloud-client')
+conflicts=('sprycloud-client')
+install=${_name}.install
+options=(!strip)
+backup=('etc/spryCloud/sync-exclude.lst')
+source=("${_name}::git+https://github.com/SpryServers/sprycloud-client-next.git"
+ "${_name}.service")
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ if [[ -z "${_version}" ]]; then
+ cd "${srcdir}/${_name}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ else
+ echo ${_version}
+ fi
+}
+
+prepare() {
+ cd "${srcdir}/${_name}"
+ if [[ -n "${_version}" ]]; then
+ git checkout "${_version}"
+ fi
+ git submodule update --init --recursive
+ mkdir -p "${srcdir}/${_name}"
+}
+
+build() {
+ cd "${srcdir}/${_name}"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc/${_name} \
+ -DWITH_DOC=FALSE \
+ -DQTKEYCHAIN_LIBRARY=/usr/lib/libqt5keychain.so \
+ -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qt5keychain/ \
+ ../${_name}
+ make
+}
+
+check() {
+ sed -Ei 's|Icon(\[.*\])?=sprycloud|Icon\1=spryCloud|g' "${srcdir}/${_name}/src/gui/sprycloud.desktop"
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${srcdir}/${_name}.service" "${pkgdir}/usr/lib/systemd/user/${_name}.service"
+}
diff --git a/sprycloud-client.install b/sprycloud-client.install
new file mode 100644
index 000000000000..a015b39f704b
--- /dev/null
+++ b/sprycloud-client.install
@@ -0,0 +1,19 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor
+ systemctl daemon-reload
+ echo ================================== Important =================================
+ echo Start the spryCloud client daemon with:
+ echo systemctl start --user sprycloud-client.service
+ echo ==============================================================================
+ echo Enable the spryCloud client daemon with:
+ echo systemctl enable --user sprycloud-client.service
+ echo ==============================================================================
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/sprycloud-client.service b/sprycloud-client.service
new file mode 100644
index 000000000000..a14c70ec3850
--- /dev/null
+++ b/sprycloud-client.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=spryCloud client
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/sprycloud
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=on-failure
+
+[Install]
+WantedBy=default.target