summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTab Fitts2021-04-02 11:46:42 -0700
committerTab Fitts2021-04-02 11:46:42 -0700
commitefe04149220c5e293360bda3e2d410ea11727fb4 (patch)
tree8159f9676012071b98abe3af2ade162152f05b45
parentb7ee3fa508ad22eb8e06fc7ff50fa457c3a82b07 (diff)
downloadaur-efe04149220c5e293360bda3e2d410ea11727fb4.tar.gz
spryCloud Release v3.1.3
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 910fc92a4c45..0ca99e95d32e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,36 @@
pkgbase = sprycloud-client-git
pkgdesc = spryCloud client for Linux
- pkgver = 3.0.3.spry.r1.r0.ge5878aa6d
+ pkgver = 3.1.3.spry.r1.r0.gb222910e0
pkgrel = 1
url = https://www.spryservers.net/
install = sprycloud-client.install
arch = i686
arch = x86_64
license = GPL2
- makedepends = cmake
- makedepends = qt5-tools
- makedepends = extra-cmake-modules
makedepends = doxygen
+ makedepends = extra-cmake-modules
+ makedepends = kio
makedepends = python-sphinx
+ makedepends = qt5-tools
+ makedepends = git
+ makedepends = cmocka
+ depends = openssl
+ depends = sqlite
depends = qtkeychain
- depends = qt5-webkit
+ depends = qt5-svg
depends = qt5-webengine
- depends = hicolor-icon-theme
depends = xdg-utils
- depends = openssl
- depends = qt5-svg
- depends = qtkeychain
- optdepends = nemo-python
- optdepends = python-nautilus
- optdepends = python-sphinx
- optdepends = doxygen
+ depends = qt5-websockets
+ depends = qt5-webkit
+ depends = libcloudproviders
+ depends = qt5-graphicaleffects
+ depends = qt5-quickcontrols2
+ depends = hicolor-icon-theme
+ optdepends = kio: integration with Dolphin
+ optdepends = nemo-python: integration with Nemo
+ optdepends = python-nautilus: integration with Nautilus
+ optdepends = python-caja: integration with Caja
+ optdepends = doxygen: documentation generation
provides = sprycloud-client
provides = sprycloud-client-git
conflicts = sprycloud-client
diff --git a/PKGBUILD b/PKGBUILD
index c3e2255ecf36..994815310eda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,24 @@
# Git: https://github.com/SpryServers/sprycloud-desktop
# Uncomment, if you want the last release
#_version=master
-_spryrel=3.0.3.spry.r1
+_spryrel=3.1.3.spry.r1
pkgname=sprycloud-client-git
_name=${pkgname/\-git/}
-pkgver=3.0.3.spry.r1.r0.ge5878aa6d
+pkgver=3.1.3.spry.r1.r0.gb222910e0
pkgrel=1
pkgdesc="spryCloud client for Linux"
arch=('i686' 'x86_64')
url="https://www.spryservers.net/"
license=('GPL2')
-depends=('qtkeychain' 'qt5-webkit' 'qt5-webengine' 'hicolor-icon-theme' 'xdg-utils' 'openssl' 'qt5-svg' 'qtkeychain')
-optdepends=('nemo-python' 'python-nautilus' 'python-sphinx' 'doxygen')
-makedepends=('cmake' 'qt5-tools' 'extra-cmake-modules' 'doxygen' 'python-sphinx')
+depends=('openssl' 'sqlite' 'qtkeychain' 'qt5-svg' 'qt5-webengine' 'xdg-utils' 'qt5-websockets' 'qt5-webkit' 'libcloudproviders' 'qt5-graphicaleffects' 'qt5-quickcontrols2' 'hicolor-icon-theme')
+optdepends=(
+ 'kio: integration with Dolphin'
+ 'nemo-python: integration with Nemo'
+ 'python-nautilus: integration with Nautilus'
+ 'python-caja: integration with Caja'
+ 'doxygen: documentation generation'
+)
+makedepends=('doxygen' 'extra-cmake-modules' 'kio' 'python-sphinx' 'qt5-tools' 'git' 'cmocka')
provides=('sprycloud-client' 'sprycloud-client-git')
conflicts=('sprycloud-client')
install=${_name}.install
@@ -48,11 +54,10 @@ build() {
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE="Release" \
+ -DWITH_DOC=FALSE \
-DNO_SHIBBOLETH=1 \
-DMIRALL_VERSION_SUFFIX=-spry-r1 \
-DMIRALL_VERSION_BUILD=${pkgrel} \
- -DQTKEYCHAIN_LIBRARY=/usr/lib/libqt5keychain.so \
- -DQTKEYCHAIN_INCLUDE_DIR=/usr/include/qt5keychain/ \
../${_name}
make
}