summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Witten2019-03-04 21:11:23 -0800
committerTyler Witten2019-03-04 21:11:23 -0800
commit9750421d7f6cac034b8cd0d4d759ca4c2bcb2c63 (patch)
tree8f5ff815007a603d73cc65aec473b0beea681bc0
downloadaur-9750421d7f6cac034b8cd0d4d759ca4c2bcb2c63.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1823d8a6081f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sprytile
+ pkgdesc = A blender addon for creating tile based low spec 3D scenes.
+ pkgver = 0.4.50
+ pkgrel = 1
+ url = https://github.com/Sprytile/Sprytile
+ arch = x86_64
+ license = MIT
+ depends = blender
+ source = https://github.com/Sprytile/Sprytile/archive/v0.4.50.tar.gz
+ md5sums = 84c88b493f52ee04034d594241b60db1
+
+pkgname = sprytile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fd1757727a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Tyler Witten <turtlewit@live.com>
+pkgname=sprytile
+pkgver=0.4.50
+pkgrel=1
+pkgdesc="A blender addon for creating tile based low spec 3D scenes."
+arch=('x86_64')
+url="https://github.com/Sprytile/Sprytile"
+license=('MIT')
+depends=('blender')
+source=("https://github.com/Sprytile/Sprytile/archive/v0.4.50.tar.gz")
+md5sums=('84c88b493f52ee04034d594241b60db1')
+
+prepare() {
+ cd "Sprytile-$pkgver"
+ echo "Disabling addon updater..."
+ echo "The addon will throw harmless errors about the updater;"
+ echo "However, the it should otherwise function normally."
+ sed -i 's/addon_updater_ops.register(bl_info)/#addon_updater_ops.register(bl_info)/' __init__.py
+}
+
+package() {
+ cd "Sprytile-$pkgver"
+ addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons"
+ install -dm755 "${addons}/SpryTile"
+ cp -r ./ "${addons}/SpryTile/"
+}