summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew-Flame2023-11-08 16:28:29 +0300
committerAndrew-Flame2023-11-08 16:28:29 +0300
commitdc1147bc29ba4273cf3f8f59a93cb31fc28e48d8 (patch)
treed5b3b290be02ef8cbadf46ddb2d67e2592410dab
downloadaur-dc1147bc29ba4273cf3f8f59a93cb31fc28e48d8.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD20
-rw-r--r--spwd.install19
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..146ffc4f9ed3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = spwd
+ pkgdesc = Program for displaying the current working directory in the shell prompt
+ pkgver = 1.0.0
+ pkgrel = 1
+ epoch = 0
+ url = https://github.com/Andrew-Flame/spwd.git
+ install = spwd.install
+ arch = any
+ license = BSD-3
+ source = https://github.com/Andrew-Flame/spwd/archive/refs/tags/v1.0.0.tar.gz
+ sha512sums = 50d91387050e18e36cefaabc9c33357a9e07706b80a93dec7245fd79ef2d9b3ec530a3c1f5ca5563734ba842b24bc4b77b7874c2bdda848be803beb14f6f0b69
+
+pkgname = spwd
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c3108bb49e81
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+!.SRCINFO
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e3c81e36f01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Evilur <andrewflame@mail.ru>
+pkgname=spwd
+pkgver=1.0.0
+pkgrel=1
+epoch=0
+pkgdesc="Program for displaying the current working directory in the shell prompt"
+arch=('any')
+url="https://github.com/Andrew-Flame/spwd.git"
+license=('BSD-3')
+install="spwd.install"
+source=("https://github.com/Andrew-Flame/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=("50d91387050e18e36cefaabc9c33357a9e07706b80a93dec7245fd79ef2d9b3ec530a3c1f5ca5563734ba842b24bc4b77b7874c2bdda848be803beb14f6f0b69")
+
+prepare() {
+ tar -xf "v${pkgver}.tar.gz"
+}
+
+package() {
+ gcc "${pkgname}-${pkgver}/spwd.c" -o /tmp/spwd.bin
+} \ No newline at end of file
diff --git a/spwd.install b/spwd.install
new file mode 100644
index 000000000000..d751633567de
--- /dev/null
+++ b/spwd.install
@@ -0,0 +1,19 @@
+pre_install() {
+ rm -f /usr/bin/spwd
+}
+
+post_install() {
+ mv /tmp/spwd.bin /usr/bin/spwd
+}
+
+pre_upgrade() {
+ rm -f /usr/bin/spwd
+}
+
+post_upgrade() {
+ mv /tmp/spwd.bin /usr/bin/spwd
+}
+
+post_remove() {
+ rm -f /usr/bin/spwd
+} \ No newline at end of file