summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122016-01-30 08:58:24 +0100
committerwillemw122016-01-30 08:58:24 +0100
commit0a2db1aa2c9df1d7648cfe7518e57c5d65ac9d73 (patch)
treec31776f90dfd055d210b80a64f3f1e66bcf2c14f
parent6c040fd88c3156791f2de920bbb5b844e67e2192 (diff)
downloadaur-0a2db1aa2c9df1d7648cfe7518e57c5d65ac9d73.tar.gz
Remove 'ipython-notebook'. Cleanup dependencies
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
2 files changed, 14 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 717331754994..77845ab0f723 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Mon Jan 25 19:31:56 UTC 2016
+# Sat Jan 30 07:55:54 UTC 2016
pkgbase = spyder-git
- pkgver = 3.0.0b2.r119.g7bae783
+ pkgver = 3.0.0b2.r130.gb269751
pkgrel = 1
url = https://github.com/spyder-ide/spyder
install = spyder-git.install
@@ -17,8 +17,8 @@ pkgbase = spyder-git
pkgname = spyder-git
pkgdesc = Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 2 version)
- depends = ipython2-notebook
depends = python2-pyqt5
+ depends = ipython2-notebook
depends = python2-pyflakes
depends = python2-sphinx
depends = python2-pygments
@@ -44,15 +44,14 @@ pkgname = spyder-git
pkgname = spyder3-git
pkgdesc = Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 3 version)
- depends = ipython-notebook
depends = python-pyqt5
+ depends = jupyter
depends = python-pyflakes
depends = python-sphinx
depends = python-pygments
depends = python-pylint
depends = pep8
depends = python-psutil
- depends = jupyter
depends = python-qtawesome
depends = python-pyzmq
depends = desktop-file-utils
diff --git a/PKGBUILD b/PKGBUILD
index b578483258ce..38eb8b22b3ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname2=spyder
_pkgname3=spyder3
pkgbase=$_pkgname2-git
pkgname=($_pkgname2-git $_pkgname3-git)
-pkgver=3.0.0b2.r119.g7bae783
+pkgver=3.0.0b2.r130.gb269751
pkgrel=1
arch=('any')
url="https://github.com/spyder-ide/spyder"
@@ -36,11 +36,12 @@ build() {
package_spyder-git() {
pkgdesc="Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 2 version)"
+ # Note: 'ipython2-notebook' contains QTConsole
+ # Note: 'ipython2' (dependency of 'ipython2-notebook') contains Pickleshare
+ # Note: 'ipython2-notebook' nor 'jupyter' contain a Python 2 version of Nbconvert
# 'icu'
- # 'jupyter' does not contain a Python 2 of Nbconvert
- # 'ipython2' ('ipython2-notebook') contains Pickleshare
- depends=('ipython2-notebook'
- 'python2-pyqt5'
+ depends=('python2-pyqt5'
+ 'ipython2-notebook'
'python2-pyflakes'
'python2-sphinx'
'python2-pygments'
@@ -52,8 +53,6 @@ package_spyder-git() {
'python2-pyzmq'
'desktop-file-utils'
'gtk-update-icon-cache')
- # 'ipython2<4.0: enhanced Python interpreter'
- # 'ipython2-notebook>=4.0: enhanced Python interpreter (qtconsole)'
optdepends=('python2-pyqt4: Qt-Python bindings'
'python2-pyside: Qt-Python bindings'
'python2-rope: editor code completion, calltips and go-to-definition'
@@ -78,26 +77,22 @@ package_spyder-git() {
package_spyder3-git() {
pkgdesc="Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 3 version)"
+ # Note: 'jupyter' contains QTConsole and Nbconvert
+ # Note: 'ipython' (dependency of 'jupyter') contains Pickleshare
# 'icu'
- # 'ipython' ('ipython-notebook') contains Pickleshare
- # 'jupyter' contains Nbconvert
- depends=('ipython-notebook'
- 'python-pyqt5'
+ depends=('python-pyqt5'
+ 'jupyter'
'python-pyflakes'
'python-sphinx'
'python-pygments'
'python-pylint'
'pep8'
'python-psutil'
- 'jupyter'
'python-qtawesome'
'python-pyzmq'
'desktop-file-utils'
'gtk-update-icon-cache')
- # 'ipython<4.0: enhanced Python interpreter'
- # 'ipython-notebook>=4.0: enhanced Python interpreter (qtconsole)'
- # 'jupyter: nbconvert - manipulation of notebooks in the Editor'
optdepends=('python-pyqt4: Qt-Python bindings'
'python-pyside: Qt-Python bindings'
'python-rope: editor code completion, calltips and go-to-definition'