summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-09-16 15:21:38 +0200
committerwillemw122015-09-16 15:21:38 +0200
commit5cdeed2b001756d9bfab47266e28c83f05009d3e (patch)
tree09232b6ea08d4f07d45be0dfa1d7153da28245ab
parent59fe9b6aee449f6370e22ecf6d5aadb3012e50c0 (diff)
downloadaur-5cdeed2b001756d9bfab47266e28c83f05009d3e.tar.gz
Fix 'provides' and 'conflicts'
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f53e7e0cb403..1dd5d460a0db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = spyder-git
- pkgver = 3.0.0b1.r134.g2e7699b
+ pkgver = 3.0.0b1.r145.gb1d9780
pkgrel = 1
url = https://github.com/spyder-ide/spyder
install = spyder-git.install
@@ -32,8 +32,8 @@ pkgname = spyder-git
optdepends = python2-matplotlib: interactive 2D/3D data plotting
optdepends = pep8-python2: real-time code style analysis
optdepends = python2-sympy: symbolic mathematics for the IPython console
- provides =
- conflicts =
+ provides = spyder
+ conflicts = spyder
pkgname = spyder3-git
pkgdesc = Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 3 version)
@@ -54,6 +54,6 @@ pkgname = spyder3-git
optdepends = python-matplotlib: interactive 2D/3D data plotting
optdepends = pep8: real-time code style analysis
optdepends = python-sympy: symbolic mathematics for the IPython console
- provides =
- conflicts =
+ provides = spyder3
+ conflicts = spyder3
diff --git a/PKGBUILD b/PKGBUILD
index 5571c7d33090..85e2d424c9ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname2=spyder
_pkgname3=spyder3
pkgbase=$_pkgname2-git
pkgname=($_pkgname2-git $_pkgname3-git)
-pkgver=3.0.0b1.r134.g2e7699b
+pkgver=3.0.0b1.r145.gb1d9780
pkgrel=1
arch=('any')
url="https://github.com/spyder-ide/spyder"
@@ -54,15 +54,14 @@ package_spyder-git() {
'python2-matplotlib: interactive 2D/3D data plotting'
'pep8-python2: real-time code style analysis'
'python2-sympy: symbolic mathematics for the IPython console')
- _pkgname='spyder'
- provides=($_pkgname)
- conflicts=($_pkgname)
+ provides=($_pkgname2)
+ conflicts=($_pkgname2)
- cd $_pkgname
+ cd $_pkgname2
python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
# Install a scalable icon for the spyder.desktop file
install -Dm644 spyderlib/images/spyder.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/spyder.svg"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname2/LICENSE"
rm "$pkgdir/usr/bin/spyder_win_post_install.py"
}
@@ -82,15 +81,14 @@ package_spyder3-git() {
'python-matplotlib: interactive 2D/3D data plotting'
'pep8: real-time code style analysis'
'python-sympy: symbolic mathematics for the IPython console')
- _pkgname='spyder3'
- provides=($_pkgname)
- conflicts=($_pkgname)
+ provides=($_pkgname3)
+ conflicts=($_pkgname3)
- cd $_pkgname
+ cd $_pkgname3
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
# Install a scalable icon for the spyder3.desktop file
install -Dm644 spyderlib/images/spyder.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/spyder3.svg"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname3/LICENSE"
rm "$pkgdir/usr/bin/spyder_win_post_install.py"
}