summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Gregoratto2019-01-12 00:08:26 +1100
committerStephen Gregoratto2019-01-12 00:08:26 +1100
commit995d098f4b01062072734adad0e94a668e587d5b (patch)
treeadaa2487d4d611de38e06c98bfd0e348c492afe1
parent934bd4c19d5d9a3d35623bab5b9165516250e37f (diff)
downloadaur-995d098f4b01062072734adad0e94a668e587d5b.tar.gz
Change pkgver/epoch, enable upstream testing, simplify stages.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD41
2 files changed, 23 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bd1f6270c90..999cd8c9316d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
-# Generated by mksrcinfo v8
-# Tue Dec 19 23:04:19 UTC 2017
pkgbase = sqawk-git
pkgdesc = Like Awk but with SQL and table joins
- pkgver = 20160510
+ pkgver = r184.658b628
pkgrel = 1
+ epoch = 1
url = https://github.com/dbohdan/sqawk
arch = i686
arch = x86_64
+ arch = armv6h
+ arch = armv7h
license = MIT
makedepends = git
depends = sqlite-tcl
depends = tcl
depends = tcllib
- source = git+https://github.com/dbohdan/sqawk
+ source = sqawk::git+https://github.com/dbohdan/sqawk
sha256sums = SKIP
pkgname = sqawk-git
diff --git a/PKGBUILD b/PKGBUILD
index f204cd621c92..87376296e2d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,38 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
-
+# Maintainer: KingofToasters <themanhimself at sgregoratto dot me>
+# Contributor: Andy Weidenbaum <archbaum at gmail dot com>
pkgname=sqawk-git
-pkgver=20160510
+epoch=1
+pkgver=r184.658b628
pkgrel=1
pkgdesc="Like Awk but with SQL and table joins"
-arch=('i686' 'x86_64')
-depends=('sqlite-tcl' 'tcl' 'tcllib')
-makedepends=('git')
url="https://github.com/dbohdan/sqawk"
license=('MIT')
-source=(git+https://github.com/dbohdan/sqawk)
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+depends=('sqlite-tcl' 'tcl' 'tcllib')
+makedepends=('git')
+source=("${pkgname%-git}::git+$url")
sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- git log -1 --format="%cd" --date=short --no-show-signature | sed "s|-||g"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd ${pkgname%-git}
-
- msg2 'Building...'
make
}
-package() {
+check() {
cd ${pkgname%-git}
+ make test
+}
- msg2 'Installing license...'
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
-
- msg2 'Installing documentation...'
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}"
- cp -dpr --no-preserve=ownership examples \
- "$pkgdir/usr/share/doc/${pkgname%-git}"
-
- msg2 'Installing...'
+package() {
+ cd ${pkgname%-git}
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}"
+ install -d "$pkgdir/usr/share/doc/${pkgname%-git}"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/${pkgname%-git}/README"
+ cp -dpr --no-preserve=ownership examples "$pkgdir/usr/share/doc/${pkgname%-git}"
make prefix=/usr DESTDIR="$pkgdir" install
-
- msg2 'Cleaning up pkgdir...'
- find "$pkgdir" -type d -name .git -exec rm -r '{}' +
}