summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-05-11 19:47:06 -0700
committerAndy Weidenbaum2016-05-11 19:47:06 -0700
commitf0580d2518c0f168203ca35d6a6680029f353e5d (patch)
tree6992ce5595d70abd504d72c7cd3f9b619785afed
parentab69ed3e172740b7ada7bd148e61b379f6569437 (diff)
downloadaur-f0580d2518c0f168203ca35d6a6680029f353e5d.tar.gz
update pkgver to 20160510
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 208ed2b53c63..e45e09d3535e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu May 12 02:46:54 UTC 2016
pkgbase = sqawk-git
pkgdesc = Like Awk but with SQL and table joins
- pkgver = 20150128
+ pkgver = 20160510
pkgrel = 1
url = https://github.com/dbohdan/sqawk
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 56c62792713b..08f5607902c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
pkgname=sqawk-git
-pkgver=20150128
+pkgver=20160510
pkgrel=1
pkgdesc="Like Awk but with SQL and table joins"
arch=('i686' 'x86_64')
@@ -17,19 +17,27 @@ pkgver() {
git log -1 --format="%cd" --date=short | sed "s|-||g"
}
+build() {
+ cd ${pkgname%-git}
+
+ msg2 'Building...'
+ make
+}
+
package() {
cd ${pkgname%-git}
- msg 'Installing license...'
- install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
- msg 'Installing documentation...'
- install -dm 755 "$pkgdir/usr/share/doc/${pkgname%-git}"
- cp -dpr --no-preserve=ownership README.md examples "$pkgdir/usr/share/doc/${pkgname%-git}"
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}"
+ cp -dpr --no-preserve=ownership examples \
+ "$pkgdir/usr/share/doc/${pkgname%-git}"
- msg 'Installing...'
- install -Dm 755 sqawk.tcl "$pkgdir/usr/bin/sqawk"
+ msg2 'Installing...'
+ make prefix=/usr DESTDIR="$pkgdir" install
- msg 'Cleaning up pkgdir...'
+ msg2 'Cleaning up pkgdir...'
find "$pkgdir" -type d -name .git -exec rm -r '{}' +
}