summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-04-04 02:07:31 +0000
committerGeorge Rawlinson2022-04-04 02:07:31 +0000
commit8d2ac39883d828e59f051fd0d74e1090a533d8eb (patch)
tree84f1aee2538296e3c316fe0a9b74900e24041fd5
parent8987f4f82da73ec1b66424b88aac46320d2e9421 (diff)
downloadaur-8d2ac39883d828e59f051fd0d74e1090a533d8eb.tar.gz
upgpkg: sqlboiler 4.9.0-1
New upstream release.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eddf6a2ea06f..e518065aa41d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sqlboiler
pkgdesc = Generate a Go ORM tailored to your database schema
- pkgver = 4.8.6
+ pkgver = 4.9.0
pkgrel = 1
url = https://github.com/volatiletech/sqlboiler
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = sqlboiler
makedepends = go
depends = glibc
options = !lto
- source = sqlboiler::git+https://github.com/volatiletech/sqlboiler.git#commit=d5757fd434da93733828fa70a222255c92f6db83
+ source = sqlboiler::git+https://github.com/volatiletech/sqlboiler.git#commit=fb61ccff2f4ef534b360334cf2f1af85e7ed8838
b2sums = SKIP
pkgname = sqlboiler
diff --git a/PKGBUILD b/PKGBUILD
index f9b7128c9201..135557e3a001 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=(
'sqlboiler-psql'
# TODO: add mysql split package
)
-pkgver=4.8.6
+pkgver=4.9.0
pkgrel=1
pkgdesc="Generate a Go ORM tailored to your database schema"
arch=('x86_64')
@@ -15,7 +15,7 @@ license=('BSD')
depends=('glibc')
makedepends=('git' 'go')
options=('!lto')
-_commit='d5757fd434da93733828fa70a222255c92f6db83'
+_commit='fb61ccff2f4ef534b360334cf2f1af85e7ed8838'
source=("$pkgbase::git+$url.git#commit=$_commit")
b2sums=('SKIP')
@@ -32,7 +32,7 @@ prepare() {
mkdir build
# download dependencies
- go mod vendor
+ go mod download
}
build() {
@@ -47,7 +47,7 @@ build() {
go build -v \
-trimpath \
-buildmode=pie \
- -mod=vendor \
+ -mod=readonly \
-modcacherw \
-ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
-o build \