summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2020-10-06 07:52:53 +0300
committersurefire2020-10-06 07:52:53 +0300
commitcf434c8bd570d0aaf0714de1b136c772ef9948e3 (patch)
tree551e05a684d621fc5164b383aebc85504bed5b73
parent62306c335c6a83df5b20e26f22f9b0e29e30a550 (diff)
downloadaur-cf434c8bd570d0aaf0714de1b136c772ef9948e3.tar.gz
upgpkg: sqlectron-gui 1.32.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD54
-rw-r--r--node.sh6
-rw-r--r--sqlectron-gui.sh2
4 files changed, 36 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e26edf2071e6..6042d1ab7523 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = sqlectron-gui
pkgdesc = A simple and lightweight SQL client with cross database and platform support
- pkgver = 1.30.0
- pkgrel = 4
+ pkgver = 1.32.0
+ pkgrel = 1
url = https://sqlectron.github.io/
arch = x86_64
license = MIT
makedepends = asar
makedepends = libsass
+ makedepends = nodejs
makedepends = npm
- depends = electron2
- source = https://github.com/sqlectron/sqlectron-gui/archive/v1.30.0.tar.gz
+ makedepends = python2
+ depends = electron5
+ source = https://github.com/sqlectron/sqlectron-gui/archive/v1.32.0.tar.gz
source = sqlectron-gui.sh
source = sqlectron-gui.desktop
- source = node.sh
- sha1sums = 467869f0678cc0e99ca268c9c3d1aafc565c130f
- sha1sums = 6ad81d34e04c1760d4be27f0e4ec25ff5267deca
+ sha1sums = f8a7c8a8367518d9acb25277a7734e7ea8e61fe8
+ sha1sums = 24ea99fbf25d936d05d197638cfad2e1dc6a6d93
sha1sums = b9fb3bc29a17dee5de9295e2fdb2b3025ed51d1f
- sha1sums = 1c03020a3cba2e4d054ff565d3b607efb8f8cf58
pkgname = sqlectron-gui
diff --git a/PKGBUILD b/PKGBUILD
index da915321410a..2dc6af8b97bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,44 +2,42 @@
# Contributor: Edison IbaƱez <edison@opmbx.org>
pkgname=sqlectron-gui
-pkgver=1.30.0
-pkgrel=4
+pkgver=1.32.0
+pkgrel=1
pkgdesc="A simple and lightweight SQL client with cross database and platform support"
arch=('x86_64')
url="https://sqlectron.github.io/"
license=('MIT')
-depends=('electron2')
+depends=('electron5')
makedepends=(
'asar'
'libsass'
+ 'nodejs'
'npm'
+ 'python2'
)
-source=("https://github.com/sqlectron/sqlectron-gui/archive/v${pkgver}.tar.gz"
- 'sqlectron-gui.sh'
- 'sqlectron-gui.desktop'
- 'node.sh'
+source=(
+ "https://github.com/sqlectron/sqlectron-gui/archive/v${pkgver}.tar.gz"
+ 'sqlectron-gui.sh'
+ 'sqlectron-gui.desktop'
)
-sha1sums=('467869f0678cc0e99ca268c9c3d1aafc565c130f'
- '6ad81d34e04c1760d4be27f0e4ec25ff5267deca'
- 'b9fb3bc29a17dee5de9295e2fdb2b3025ed51d1f'
- '1c03020a3cba2e4d054ff565d3b607efb8f8cf58')
+sha1sums=('f8a7c8a8367518d9acb25277a7734e7ea8e61fe8'
+ '24ea99fbf25d936d05d197638cfad2e1dc6a6d93'
+ 'b9fb3bc29a17dee5de9295e2fdb2b3025ed51d1f')
prepare() {
cd "$pkgname-$pkgver"
# remove extra dependencies
sed -i package.json \
- -e '/"node-sass":/ s/3\.4\.2/4.11.0/' \
-e '/"postinstall":/ d' \
-e '/"electron":/ d' \
-e '/"electron-builder":/ d' \
-e '/"spawn-auto-restart":/ d' \
-e '/"webpack-dev-middleware":/ d' \
-e '/"webpack-dev-server":/ d' \
- -e '/"webpack-bundle-analyzer":/ s/,$//'
-
- install -Dm0755 "$srcdir/node.sh" "$srcdir/bin/node"
+ -e '/"webpack-cli":/ s/,$//'
}
build() {
@@ -49,27 +47,28 @@ build() {
export SASS_FORCE_BUILD=1
export LIBSASS_EXT=auto
export npm_config_optional=false
- export npm_config_nodedir=/usr/lib/electron2/node
export npm_config_scripts_prepend_node_path=false
+ export npm_config_build_from_source=true
+ export npm_config_sqlite=/usr
- npm install --build-from-source
+ npm install
npm run compile:browser
npm run compile:renderer
mkdir app
- mv -t ./app out
- cp -t ./app package.json
+ mv -t app out
+ cp -rt app build package.json
- pushd app
- npm install \
- --production \
- --build-from-source \
- --runtime=electron \
- --target=$(</usr/lib/electron2/version)
- popd
+ cd app
- asar p app app.asar
+ export npm_config_arch=x64
+ export npm_config_target_arch=x64
+ export npm_config_runtime=electron
+ export npm_config_target=$(</usr/lib/electron5/version)
+ export npm_config_disturl=https://electronjs.org/headers
+
+ HOME="$srcdir/.electron-gyp" npm install --production
}
package() {
@@ -79,6 +78,7 @@ package() {
install -Dm0644 build/app.png "${pkgdir}/usr/share/pixmaps/sqlectron-gui.png"
+ asar p app app.asar
install -Dm0644 -t "${pkgdir}/usr/lib/sqlectron-gui" app.asar
install -Dm0644 -t "${pkgdir}/usr/share/applications" ../sqlectron-gui.desktop
diff --git a/node.sh b/node.sh
deleted file mode 100644
index 2054c593a660..000000000000
--- a/node.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-export ELECTRON_RUN_AS_NODE=1
-export ELECTRON_NO_ASAR=1
-
-exec /usr/lib/electron2/electron "$@"
diff --git a/sqlectron-gui.sh b/sqlectron-gui.sh
index 0370598e24fb..d323428199dd 100644
--- a/sqlectron-gui.sh
+++ b/sqlectron-gui.sh
@@ -1,3 +1,3 @@
#!/usr/bin/sh
-exec electron2 /usr/lib/sqlectron-gui/app.asar "$@"
+exec electron5 /usr/lib/sqlectron-gui/app.asar "$@"