summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThibault Boyeux2021-02-01 10:32:14 +0000
committerThibault Boyeux2021-02-01 10:32:14 +0000
commit383ff7a311f66ffd82aac85b70931c89b46d24a6 (patch)
tree2d66c0c2f027120d62c472a39da2ae1f5787306a
parente513c3963462b4200380ff0ab1dd7d2cb323cd78 (diff)
downloadaur-383ff7a311f66ffd82aac85b70931c89b46d24a6.tar.gz
Update PKGBUILD and .SRCINFO with GitHub Actions
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f47f523fcf96..7181dc0aa7c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sqlite-fts3-parenthesis
pkgdesc = A C library that implements an SQL database engine. Compiled with 'SQLITE_ENABLE_FTS3_PARENTHESIS' option to allow operators AND and NOT and nested parenthesis in queries.
- pkgver = 3.34.0
+ pkgver = 3.34.1
pkgrel = 1
url = https://www.sqlite.org/
arch = x86_64
@@ -8,13 +8,13 @@ pkgbase = sqlite-fts3-parenthesis
makedepends = tcl
depends = readline
depends = zlib
- provides = sqlite=3.34.0
+ provides = sqlite=3.34.1
conflicts = sqlite
replaces = sqlite3
options = !emptydirs
options = !makeflags
- source = https://www.sqlite.org/2020/sqlite-src-3340000.zip
- sha256sums = a5c2000ece56d2de13c474658b9cdba6b7f2608a4d711e245518ea02a2a2333e
+ source = https://www.sqlite.org/2021/sqlite-src-3340100.zip
+ sha256sums = dddd237996b096dee8b37146c7a37a626a80306d6695103d2ec16ee3b852ff49
pkgname = sqlite-fts3-parenthesis
diff --git a/PKGBUILD b/PKGBUILD
index 995f01fcf72b..3bbd310546fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=('sqlite-fts3-parenthesis')
-_srcver=3340000
+_srcver=3340100
_docver=${_srcver}
-pkgver=3.34.0
+pkgver=3.34.1
pkgrel=1
pkgdesc="A C library that implements an SQL database engine. Compiled with 'SQLITE_ENABLE_FTS3_PARENTHESIS' option to allow operators AND and NOT and nested parenthesis in queries."
arch=('x86_64')
@@ -16,10 +16,10 @@ depends=('readline' 'zlib')
conflicts=("sqlite")
provides=("sqlite=$pkgver")
replaces=("sqlite3")
-source=(https://www.sqlite.org/2020/sqlite-src-${_srcver}.zip)
+source=(https://www.sqlite.org/2021/sqlite-src-${_srcver}.zip)
options=('!emptydirs' '!makeflags') # json extensions breaks parallel build
-# upstream now switched to sha3sums - currently not suppoerted by makepkg
-sha256sums=('a5c2000ece56d2de13c474658b9cdba6b7f2608a4d711e245518ea02a2a2333e')
+# upstream now switched to sha3sums - currently not supported by makepkg
+sha256sums=('dddd237996b096dee8b37146c7a37a626a80306d6695103d2ec16ee3b852ff49')
package() {
cd sqlite-src-$_srcver
@@ -33,6 +33,7 @@ package() {
# license - no linking required because pkgbase=pkgname
install -D -m644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
# split out tcl extension
mkdir "$srcdir"/tcl
mv "$pkgdir"/usr/lib/sqlite* "$srcdir"/tcl