summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-12-23 20:24:47 -0500
committerVincent Grande2020-12-23 20:24:47 -0500
commit5e80a2514d84fe085c486e9543614a94941ebf1f (patch)
tree82ce16b16daeae09357b950e999099a2176bbbd7
parentb2d71d39b735ba6adf8b3db3fcffbe3f721a5e7c (diff)
downloadaur-5e80a2514d84fe085c486e9543614a94941ebf1f.tar.gz
fix
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD19
-rw-r--r--sqlite-lemon-system-template.patch21
3 files changed, 39 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 605aef46d4b7..a9387d4ea5b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,12 +5,13 @@ pkgbase = sqlite-minimal-git
url = https://www.sqlite.org/
arch = x86_64
license = custom:Public Domain
- makedepends = tcl
makedepends = readline
makedepends = zlib
options = !emptydirs
source = git+https://github.com/sqlite/sqlite
source = license.txt
+ source = sqlite-lemon-system-template.patch
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3563fb8e07a8..47c32d1728b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,25 @@ pkgdesc="A C library that implements an SQL database engine"
arch=('x86_64')
license=('custom:Public Domain')
url="https://www.sqlite.org/"
-makedepends=('tcl' 'readline' 'zlib')
+makedepends=('readline' 'zlib')
source=("git+https://github.com/sqlite/sqlite"
- 'license.txt')
+ 'license.txt'
+ 'sqlite-lemon-system-template.patch')
options=('!emptydirs')
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd sqlite
+
+ # patch taken from Fedora
+ # https://src.fedoraproject.org/rpms/sqlite/blob/master/f/sqlite.spec
+ # patch -Np1 -i ../sqlite-lemon-system-template.patch
+
+ # autoreconf -vfi
+}
+
build() {
export CPPFLAGS="$CPPFLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 \
diff --git a/sqlite-lemon-system-template.patch b/sqlite-lemon-system-template.patch
new file mode 100644
index 000000000000..3d3b0aa44117
--- /dev/null
+++ b/sqlite-lemon-system-template.patch
@@ -0,0 +1,21 @@
+diff -up sqlite-3.6.23/tool/lemon.c.system-template sqlite-3.6.23/tool/lemon.c
+--- sqlite-3.6.23/tool/lemon.c.system-template 2010-03-10 16:40:35.000000000 +0200
++++ sqlite-3.6.23/tool/lemon.c 2010-03-10 16:40:39.000000000 +0200
+@@ -3363,6 +3363,8 @@ PRIVATE FILE *tplt_open(struct lemon *le
+ tpltname = buf;
+ }else if( access(templatename,004)==0 ){
+ tpltname = templatename;
++ }else if( access("/usr/share/lemon/lempar.c", R_OK)==0){
++ tpltname = "/usr/share/lemon/lempar.c";
+ }else{
+ tpltname = pathsearch(lemp->argv0,templatename,0);
+ }
+@@ -3374,7 +3376,7 @@ PRIVATE FILE *tplt_open(struct lemon *le
+ }
+ in = fopen(tpltname,"rb");
+ if( in==0 ){
+- fprintf(stderr,"Can't open the template file \"%s\".\n",templatename);
++ fprintf(stderr,"Can't open the template file \"%s\".\n",tpltname);
+ lemp->errorcnt++;
+ return 0;
+ }