summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-04 16:52:17 +0800
committerzxp198210052024-03-04 16:52:17 +0800
commit195cd65af3b463d8dceccb8ea7e97a39b59851d1 (patch)
tree7c68b68226beb3b60f343f5e60d2f2ab1273508b
parentebe3cc91d5836fd09a662566d335b3ce5a2d8103 (diff)
downloadaur-195cd65af3b463d8dceccb8ea7e97a39b59851d1.tar.gz
update to 1.0.r68.g8f9786c
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--sqlite3-page-explorer.sh9
3 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3229ac36d6f..db9b3ebf7597 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sqlite3-page-explorer-git
pkgdesc = Cross Platform app to explore internal organisation of tables and indices
- pkgver = 1.0.r57.g746d603
+ pkgver = 1.0.r68.g8f9786c
pkgrel = 1
url = https://github.com/siara-cc/sqlite3_page_explorer
arch = any
@@ -10,11 +10,11 @@ pkgbase = sqlite3-page-explorer-git
makedepends = nodejs
makedepends = gendesk
depends = electron22
- provides = sqlite3-page-explorer=1.0.r57.g746d603
+ provides = sqlite3-page-explorer=1.0.r68.g8f9786c
conflicts = sqlite3-page-explorer
source = sqlite3-page-explorer.git::git+https://github.com/siara-cc/sqlite3_page_explorer.git
source = sqlite3-page-explorer.sh
sha256sums = SKIP
- sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
pkgname = sqlite3-page-explorer-git
diff --git a/PKGBUILD b/PKGBUILD
index 31e2e3944746..23d826848e2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=sqlite3-page-explorer-git
-pkgver=1.0.r57.g746d603
+pkgver=1.0.r68.g8f9786c
_electronversion=22
pkgrel=1
pkgdesc="Cross Platform app to explore internal organisation of tables and indices"
@@ -23,7 +23,7 @@ source=(
"${pkgname%-git}.sh"
)
sha256sums=('SKIP'
- '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
pkgver() {
cd "${srcdir}/${pkgname%-git}.git"
git describe --long --tags --exclude='*[a-z][a-z]*' | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
@@ -33,7 +33,7 @@ build() {
-e "s|@appname@|${pkgname%-git}|g" \
-e "s|@appasar@|app|g" \
-i "${srcdir}/${pkgname%-git}.sh"
- gendesk -q -f -n --categories "Development" --name "${pkgname%-git}" --exec "${pkgname%-git} --no-sandbox %U"
+ gendesk -q -f -n --categories="Development" --name="${pkgname%-git}" --exec="${pkgname%-git} %U"
cd "${srcdir}/${pkgname%-git}.git"
export npm_config_build_from_source=true
export npm_config_cache="${srcdir}/.npm_cache"
diff --git a/sqlite3-page-explorer.sh b/sqlite3-page-explorer.sh
index 0d20cddc70ca..86cb3dc6a9bf 100644
--- a/sqlite3-page-explorer.sh
+++ b/sqlite3-page-explorer.sh
@@ -1,14 +1,15 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file