summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engeström2015-06-09 01:33:56 +0200
committerEric Engeström2015-06-09 01:33:56 +0200
commit65e486c4ca1abc2bb15460cf45211f17f36f97e6 (patch)
tree0c27e47884dd3ca28728d70ae4c7f02d35a35606
downloadaur-65e486c4ca1abc2bb15460cf45211f17f36f97e6.tar.gz
initial commit - r43.fc0ca86-1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD35
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41b4e479aa6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sqlite3pp-git
+ pkgdesc = C++ wrapper of SQLite3 API
+ pkgver = r43.fc0ca86
+ pkgrel = 1
+ url = https://github.com/iwongu/sqlite3pp
+ arch = i686
+ arch = x86_64
+ depends = boost
+ depends = sqlite3
+ source = git+https://github.com/iwongu/sqlite3pp
+ md5sums = SKIP
+
+pkgname = sqlite3pp-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d43100301987
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+sqlite3pp/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d54321d958c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=sqlite3pp-git
+pkgver=r43.fc0ca86
+pkgrel=1
+pkgdesc="C++ wrapper of SQLite3 API"
+arch=('i686' 'x86_64')
+url="https://github.com/iwongu/sqlite3pp"
+depends=(boost sqlite3)
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "sqlite3pp"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "sqlite3pp/sqlite3pp/src"
+ cxx='c++ -std=c++11 -fPIC -shared'
+ ${cxx} -o libsqlite3pp.so sqlite3pp.cpp
+ ${cxx} -o libsqlite3ppext.so sqlite3ppext.cpp
+}
+
+package() {
+ cd "sqlite3pp/sqlite3pp/src"
+
+ # Headers
+ install -d "$pkgdir/usr/include/"
+ install -Dm644 *.h "$pkgdir/usr/include/"
+
+ # Shared objects
+ install -d "$pkgdir/usr/lib/"
+ install -Dm644 *.so "$pkgdir/usr/lib/"
+}