summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Li2016-01-29 13:24:21 -0800
committerAllen Li2016-01-29 13:24:21 -0800
commit53342bc54bd14c4ae88ea94cf314d34c9ca0a5a0 (patch)
treecda5369cfb186ec2eab9aa0962f002926911ce6b
downloadaur-53342bc54bd14c4ae88ea94cf314d34c9ca0a5a0.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD44
-rw-r--r--sqlitebrowser.install13
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3a9bf13e46e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Jan 29 21:23:29 UTC 2016
+pkgbase = sqlitebrowser-git
+ pkgdesc = SQLite Database browser is a light GUI editor for SQLite databases, built on top of Qt
+ pkgver = v3.8.0.r31.g1efec0c
+ pkgrel = 1
+ url = http://sqlitebrowser.org/
+ install = sqlitebrowser.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = sqlite
+ depends = libxkbcommon-x11
+ provides = sqlitebrowser
+ conflicts = sqlitebrowser
+ source = sqlitebrowser-git::git+https://github.com/sqlitebrowser/sqlitebrowser.git
+ md5sums = SKIP
+
+pkgname = sqlitebrowser-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..40715a7e463b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+!.git*
+!PKGBUILD
+!pkg
+!src
+!*.install
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9150ce863cd7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: darkfeline@felesatra.moe
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Douglas Soares de Andrade <dsandrade@gmail.com>
+# Contributor: Michael Fellinger <m.fellinger@gmail.com>
+
+pkgname=sqlitebrowser-git
+pkgver=v3.8.0.r31.g1efec0c
+pkgrel=1
+pkgdesc="SQLite Database browser is a light GUI editor for SQLite databases, built on top of Qt"
+arch=('i686' 'x86_64')
+url="http://sqlitebrowser.org/"
+license=('GPL')
+provides='sqlitebrowser'
+conflicts='sqlitebrowser'
+depends=('qt5-base' 'sqlite' 'libxkbcommon-x11')
+makedepends=('cmake' 'qt5-tools')
+install=sqlitebrowser.install
+source=($pkgname'::git+https://github.com/sqlitebrowser/sqlitebrowser.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/^non-daw-v//;s/-/./g'
+}
+
+prepare() {
+ cd $srcdir/$pkgname
+ sed -i 's|Icon=.*|Icon=sqlitebrowser|' distri/sqlitebrowser.desktop
+}
+
+build() {
+ cd $srcdir/$pkgname
+ cmake -DUSE_QT5=TRUE -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname
+ make install DESTDIR=$pkgdir
+ install -Dm0644 distri/sqlitebrowser.desktop $pkgdir/usr/share/applications/sqlitebrowser.desktop
+ install -dm0755 $pkgdir/usr/share/icons/
+ install -m0644 images/sqlitebrowser.svg $pkgdir/usr/share/icons/
+}
diff --git a/sqlitebrowser.install b/sqlitebrowser.install
new file mode 100644
index 000000000000..7f3cc435872b
--- /dev/null
+++ b/sqlitebrowser.install
@@ -0,0 +1,13 @@
+post_install() {
+ [[ -x usr/bin/update-desktop-database ]] && update-desktop-database -q || true
+ [[ -x usr/bin/gtk-update-icon-cache ]] && gtk-update-icon-cache -q -t -f usr/share/icons/hicolor || true
+}
+
+post_upgrade() {
+ post_install
+}
+
+
+post_remove() {
+ post_install
+}