summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsum012020-08-19 12:06:26 -0400
committersum012020-08-19 12:06:26 -0400
commit45e46c4da3e7bdfa1c60fdcab6a5dd7f40d2fd75 (patch)
treea615122b86bb8c6dd24299d5500bd8f7e7acfb7e
parent371ca55f35a4e617cabb348933da056ec018a3dd (diff)
downloadaur-45e46c4da3e7bdfa1c60fdcab6a5dd7f40d2fd75.tar.gz
v3.1.1
Doesn't need the patch to build anymore, as it was merged upstream.
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-compilation-if-using-SQLITE_HAS_CODEC.patch68
-rw-r--r--PKGBUILD12
3 files changed, 6 insertions, 82 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ed3f79ca2e5..746b18c92cd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sqlitecpp
pkgdesc = A smart and easy to use C++ SQLite3 wrapper.
- pkgver = 3.1.0
+ pkgver = 3.1.1
pkgrel = 1
url = https://github.com/SRombauts/SQLiteCpp
arch = i686
@@ -9,10 +9,8 @@ pkgbase = sqlitecpp
makedepends = cmake>=3.1
depends = sqlite>=3.19
optdepends = sqlcipher: for database encryption API
- source = sqlitecpp-3.1.0::https://github.com/SRombauts/SQLiteCpp/archive/3.1.0.tar.gz
- source = 0001-Fix-compilation-if-using-SQLITE_HAS_CODEC.patch
- sha512sums = 2415f2c775a9c1c4cf709cfbd9e130fbf96a116b5b526c78fc03c87fba6b91058c03584e7b1700b37063c5232ff4b93eb8f30506624cb3f507f9787bcb2e6864
- sha512sums = 355ca5c9b0b26c5d9006227fb998fd2704fbbc2cdc9d9a75193b8046061d3e879df692041e9124144422ae612c3c8e40beabb6c93b10b9e8dbe245dcec85c2ca
+ source = sqlitecpp-3.1.1::https://github.com/SRombauts/SQLiteCpp/archive/3.1.1.tar.gz
+ sha512sums = 9030b5249c149db8a5b2fe350f71613e4ee91061765a771640ed3ffa7c24aada4000ba884ef91790fdc0f13dc4519038c1edeba64b85b85ac09c3e955a7988a1
pkgname = sqlitecpp
diff --git a/0001-Fix-compilation-if-using-SQLITE_HAS_CODEC.patch b/0001-Fix-compilation-if-using-SQLITE_HAS_CODEC.patch
deleted file mode 100644
index fdf577511128..000000000000
--- a/0001-Fix-compilation-if-using-SQLITE_HAS_CODEC.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 15b307a09973d74bc20fda6d2b9789572e1bb67a Mon Sep 17 00:00:00 2001
-From: sum01 <sum01@protonmail.com>
-Date: Tue, 11 Aug 2020 14:51:31 -0400
-Subject: [PATCH] Fix compilation if using SQLITE_HAS_CODEC
-
-It was failing to compile since it wasn't linking against the sqlcipher
-library if using the system libraries. This fix simply links the library
-& includes the header path.
-
-PkgConf is optional in this process, and it will fall back to regular
-search for header & lib if it's not installed.
----
- CMakeLists.txt | 39 +++++++++++++++++++++++++++++++++++++++
- 1 file changed, 39 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 810a993..2d80cb4 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -239,6 +239,45 @@ else (SQLITECPP_INTERNAL_SQLITE)
- if(SQLite3_VERSION VERSION_LESS "3.19")
- set_target_properties(SQLiteCpp PROPERTIES COMPILE_FLAGS "-DSQLITECPP_HAS_MEM_STRUCT")
- endif()
-+
-+ # When using the SQLite codec, we need to link against the sqlcipher lib & include <sqlcipher/sqlite3.h>
-+ # So this gets the lib & header, and links/includes everything
-+ if(SQLITE_HAS_CODEC)
-+ # Make PkgConfig optional since Windows doesn't usually have it installed.
-+ find_package(PkgConfig QUIET)
-+ if(PKG_CONFIG_FOUND)
-+ # IMPORTED_TARGET was added in 3.6.3
-+ if(CMAKE_VERSION VERSION_LESS 3.6.3)
-+ pkg_check_modules(sqlcipher REQUIRED sqlcipher)
-+ # Only used in Database.cpp so PRIVATE to hide from end-user
-+ # Since we can't use IMPORTED_TARGET on this older Cmake version, manually link libs & includes
-+ target_link_libraries(SQLiteCpp PRIVATE ${sqlcipher_LIBRARIES})
-+ target_include_directories(SQLiteCpp PRIVATE ${sqlcipher_INCLUDE_DIRS})
-+ else()
-+ pkg_check_modules(sqlcipher REQUIRED IMPORTED_TARGET sqlcipher)
-+ # Only used in Database.cpp so PRIVATE to hide from end-user
-+ target_link_libraries(SQLiteCpp PRIVATE PkgConfig::sqlcipher)
-+ endif()
-+ else()
-+ # Since we aren't using pkgconf here, find it manually
-+ find_library(sqlcipher_LIBRARY "sqlcipher")
-+ find_path(sqlcipher_INCLUDE_DIR "sqlcipher/sqlite3.h"
-+ PATH_SUFFIXES
-+ "include"
-+ "includes"
-+ )
-+ # Hides it from the GUI
-+ mark_as_advanced(sqlcipher_LIBRARY sqlcipher_INCLUDE_DIR)
-+ if(NOT sqlcipher_INCLUDE_DIR)
-+ message(FATAL_ERROR "${PROJECT_NAME} requires the \"<sqlcipher/sqlite3.h>\" header to use the codec functionality but it wasn't found.")
-+ elseif(NOT sqlcipher_LIBRARY)
-+ message(FATAL_ERROR "${PROJECT_NAME} requires the sqlcipher library to use the codec functionality but it wasn't found.")
-+ endif()
-+ # Only used in Database.cpp so PRIVATE to hide from end-user
-+ target_include_directories(SQLiteCpp PRIVATE "${sqlcipher_INCLUDE_DIR}/sqlcipher")
-+ target_link_libraries(SQLiteCpp PRIVATE ${sqlcipher_LIBRARY})
-+ endif()
-+ endif()
- endif (SQLITECPP_INTERNAL_SQLITE)
-
- # Link target with pthread and dl for Unix
---
-2.28.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 8ae5ca170caa..ae462338f96a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: sum01 <sum01@protonmail.com>
pkgname=sqlitecpp
_dirname='SQLiteCpp'
-pkgver=3.1.0
+pkgver=3.1.1
pkgrel=1
pkgdesc='A smart and easy to use C++ SQLite3 wrapper.'
arch=('i686' 'x86_64')
@@ -12,14 +12,8 @@ license=('MIT')
depends=('sqlite>=3.19')
optdepends=('sqlcipher: for database encryption API')
makedepends=('cmake>=3.1')
-source=("$pkgname-$pkgver::https://github.com/SRombauts/SQLiteCpp/archive/${pkgver}.tar.gz"
- '0001-Fix-compilation-if-using-SQLITE_HAS_CODEC.patch')
-sha512sums=('2415f2c775a9c1c4cf709cfbd9e130fbf96a116b5b526c78fc03c87fba6b91058c03584e7b1700b37063c5232ff4b93eb8f30506624cb3f507f9787bcb2e6864'
- '355ca5c9b0b26c5d9006227fb998fd2704fbbc2cdc9d9a75193b8046061d3e879df692041e9124144422ae612c3c8e40beabb6c93b10b9e8dbe245dcec85c2ca')
-prepare() {
- cd "$_dirname-$pkgver"
- patch --forward --strip=1 --input="${srcdir}/0001-Fix-compilation-if-using-SQLITE_HAS_CODEC.patch"
-}
+source=("$pkgname-$pkgver::https://github.com/SRombauts/SQLiteCpp/archive/${pkgver}.tar.gz")
+sha512sums=('9030b5249c149db8a5b2fe350f71613e4ee91061765a771640ed3ffa7c24aada4000ba884ef91790fdc0f13dc4519038c1edeba64b85b85ac09c3e955a7988a1')
build() {
_has_sqlcipher='false'