summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Turner2018-08-28 19:09:49 -0400
committerWilliam Turner2018-08-28 19:09:49 -0400
commit1764fe1d2f24c8e44179cafecab62108426c2a21 (patch)
tree40b29c0c0d41f952223e0a8b3bf17b3569dc5e74
parent32398f77cef5f0906ca167be583ea8cc7050724b (diff)
downloadaur-1764fe1d2f24c8e44179cafecab62108426c2a21.tar.gz
Bump to 0.32.6
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
-rw-r--r--sqlops.desktop10
3 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9e6687d6fbb..97902320d323 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = sqlops
pkgdesc = SQL Operations Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW from Windows, macOS and Linux.
- pkgver = 0.32.1
+ pkgver = 0.32.6
pkgrel = 1
url = https://github.com/Microsoft/sqlopsstudio
arch = x86_64
license = custom: microsoft
+ makedepends = sed
depends = fontconfig
depends = libxtst
depends = gtk2
@@ -22,10 +23,10 @@ pkgbase = sqlops
depends = curl
optdepends = krb5: Windows authentication support
options = staticlibs
- source = https://github.com/Microsoft/sqlopsstudio/releases/download/0.32.1/sqlops-linux-0.32.1.tar.gz
+ source = https://github.com/Microsoft/sqlopsstudio/releases/download/0.32.6/sqlops-linux-0.32.6.tar.gz
source = sqlops.desktop
- sha256sums = 878407416d6c6d5b4e796ef8d2b6f05bb25da43f0b3474f29074b25c044c8361
- sha256sums = b5ad95bef9b56aba179c642e0edac04c32aa8cb3c4c0428cf0257119995e1dc2
+ sha256sums = 7464398beb8856d928fea68dddf03622e4eb4c18d39a45c03549757553b018a7
+ sha256sums = b14a6335e172e0da67ba777b9cd8ae82c23fc8002dfce8c1f5b0f0388a42d7ee
pkgname = sqlops
diff --git a/PKGBUILD b/PKGBUILD
index 7a13eb237b72..7c6c388b0285 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: William Turner <willtur.will@gmail.com>
pkgname=sqlops
-pkgver=0.32.1
+pkgver=0.32.6
pkgrel=1
pkgdesc="SQL Operations Studio is a data management tool that enables you to work with SQL Server, Azure SQL DB and SQL DW from Windows, macOS and Linux."
arch=('x86_64')
url="https://github.com/Microsoft/sqlopsstudio"
license=('custom: microsoft')
depends=('fontconfig' 'libxtst' 'gtk2' 'python' 'cairo' 'alsa-lib' 'nss' 'gcc-libs' 'glibc' 'libxss' 'gconf' 'libxkbfile' 'libunwind' 'libsecret' 'curl')
+makedepends=('sed')
optdepends=('krb5: Windows authentication support')
options=('staticlibs')
source=("https://github.com/Microsoft/sqlopsstudio/releases/download/${pkgver}/sqlops-linux-${pkgver}.tar.gz"
'sqlops.desktop')
-sha256sums=('878407416d6c6d5b4e796ef8d2b6f05bb25da43f0b3474f29074b25c044c8361'
- 'b5ad95bef9b56aba179c642e0edac04c32aa8cb3c4c0428cf0257119995e1dc2')
+sha256sums=('7464398beb8856d928fea68dddf03622e4eb4c18d39a45c03549757553b018a7'
+ 'b14a6335e172e0da67ba777b9cd8ae82c23fc8002dfce8c1f5b0f0388a42d7ee')
package() {
install -d "${pkgdir}/usr/share/${pkgname}"
@@ -23,10 +24,11 @@ package() {
# Symlink the startup script in /usr/bin
install -d "${pkgdir}/usr/bin"
- ln -s "/usr/share/${pkgname}/bin/sqlops" "${pkgdir}/usr/bin/sqlops"
+ ln -s "/usr/share/${pkgname}/bin/sqlops" "${pkgdir}/usr/bin/${pkgname}"
# Add the .desktop file
install -D -m644 "${srcdir}/sqlops.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ sed -i "s/{pkgname}/${pkgname}/g" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
# Install the license file
install -D -m644 "${srcdir}/sqlops-linux-x64/resources/app/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
diff --git a/sqlops.desktop b/sqlops.desktop
index 70a99b2b2e90..a068d275c482 100644
--- a/sqlops.desktop
+++ b/sqlops.desktop
@@ -1,9 +1,9 @@
[Desktop Entry]
Name=SQL Operations Studio
-Comment=SQL Operations Studio
+Comment=Data Management Tool that enables you to work with SQL Server, Azure SQL DB and SQL DW from Windows, macOS and Linux.
GenericName=Text Editor
-Exec=/usr/bin/sqlops --unity-launch %F
-Icon=/usr/share/sqlops/resources/app/resources/linux/code.png
+Exec=/usr/bin/{pkgname} --unity-launch %F
+Icon=/usr/share/{pkgname}/resources/app/resources/linux/code.png
Type=Application
StartupNotify=true
StartupWMClass=sqlops
@@ -14,5 +14,5 @@ Keywords=sqlops;
[Desktop Action new-empty-window]
Name=New Empty Window
-Exec=/usr/share/sqlops/sqlops --new-window %F
-Icon=sqlops
+Exec=/usr/bin/{pkgname} --new-window %F
+Icon=/usr/share/{pkgname}/resources/app/resources/linux/code.png