summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2013-11-11 16:47:45 +0100
committerCarsten Teibes2013-11-11 16:47:45 +0100
commit358939af317dd4460b241638e19720429679f49e (patch)
tree52f0c75d05817812c038d93785e5126ca6945595
downloadaur-358939af317dd4460b241638e19720429679f49e.tar.gz
[add] sqrxz2 0.80
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD51
-rw-r--r--sqrxz2.desktop8
-rw-r--r--sqrxz2.install20
-rw-r--r--sqrxz2.pngbin0 -> 1678 bytes
-rw-r--r--sqrxz2.sh5
6 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c7bdc2b8618
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = sqrxz2
+ pkgdesc = A fast paced jump'n'run which will please the hardcore gamer amongst you.
+ pkgver = 0.80
+ pkgrel = 1
+ url = http://sqrxz.de/
+ install = sqrxz2.install
+ arch = i686
+ arch = x86_64
+ license = Freeware
+ depends = sdl_mixer
+ depends = zlib
+ options = !strip
+ source = http://www.retroguru.com/sqrxz2/sqrxz2-v0.80-ubuntu.zip
+ source = sqrxz2.png
+ source = sqrxz2.sh
+ source = sqrxz2.desktop
+ md5sums = fadc7b02c01b6726e8b7a3a92cc9d578
+ md5sums = d10c83b355d87098251b076fe98a70e0
+ md5sums = 6ccbb96f4adde66cbefb04d3c947af1f
+ md5sums = fcc03a661f0d02a00bb0d85b7c13575a
+
+pkgname = sqrxz2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c98c883c1da6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: cars10t <carsten.1 gmx.net>
+
+pkgname=sqrxz2
+pkgver=0.80
+pkgrel=1
+pkgdesc="A fast paced jump'n'run which will please the hardcore gamer amongst you."
+arch=('i686' 'x86_64')
+url="http://sqrxz.de/"
+license=('Freeware')
+depends=('sdl_mixer' 'zlib')
+source=("http://www.retroguru.com/${pkgname}/${pkgname}-v${pkgver}-ubuntu.zip"
+ "${pkgname}.png"
+ "${pkgname}.sh"
+ "${pkgname}.desktop")
+md5sums=('fadc7b02c01b6726e8b7a3a92cc9d578'
+ 'd10c83b355d87098251b076fe98a70e0'
+ '6ccbb96f4adde66cbefb04d3c947af1f'
+ 'fcc03a661f0d02a00bb0d85b7c13575a')
+options=(!strip)
+install=${pkgname}.install
+
+package() {
+ cd "${srcdir}/"
+
+ # use correct arch
+ case ${CARCH} in
+ i686)
+ cp ${pkgname}_ubuntu32 $pkgname
+ ;;
+ x86_64)
+ cp ${pkgname}_ubuntu64 $pkgname
+ ;;
+ esac
+
+ # install binary, data, text, icon and desktop files
+ install -Dm755 "${pkgname}" "${pkgdir}/opt/${pkgname}/${pkgname}"
+ install -Dm755 "${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+
+ mkdir -p "${pkgdir}/opt/${pkgname}/data"
+ install -Dm644 data/*.zda "${pkgdir}/opt/${pkgname}/data"
+
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 *.txt "${pkgdir}/usr/share/doc/${pkgname}"
+
+ install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # fix permissions
+ chgrp -R games ${pkgdir}/opt/${pkgname}
+ chmod g+w ${pkgdir}/opt/${pkgname}
+}
diff --git a/sqrxz2.desktop b/sqrxz2.desktop
new file mode 100644
index 000000000000..315e6058be4e
--- /dev/null
+++ b/sqrxz2.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=sqrxz2
+Exec=sqrxz2
+Icon=sqrxz2
+Type=Application
+Comment=A fast paced jump'n'run which will please the hardcore gamer amongst you.
+Categories=Game;
+Terminal=false
diff --git a/sqrxz2.install b/sqrxz2.install
new file mode 100644
index 000000000000..9b63e14fc966
--- /dev/null
+++ b/sqrxz2.install
@@ -0,0 +1,20 @@
+
+post_install() {
+ # updates for our .desktop file
+ update-desktop-database -q
+
+ echo "You need to be in the games group for save functionality"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ # updates for our .desktop file
+ update-desktop-database -q
+
+ if [ -d /opt/sqrxz2 ]; then
+ echo "You may safely delete /opt/sqrxz2 and it's contents (config/highscore files) if you don't need them."
+ fi
+}
diff --git a/sqrxz2.png b/sqrxz2.png
new file mode 100644
index 000000000000..7c3bb03b41fa
--- /dev/null
+++ b/sqrxz2.png
Binary files differ
diff --git a/sqrxz2.sh b/sqrxz2.sh
new file mode 100644
index 000000000000..dac0343d20bf
--- /dev/null
+++ b/sqrxz2.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd /opt/sqrxz2
+./sqrxz2 "$@"
+cd - &>/dev/null