summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2016-03-12 08:25:45 +0100
committerJan Cholasta2016-03-12 08:25:45 +0100
commit8bf31b88f3311c7a7d08f78a955d229f681d2e2b (patch)
tree12c048422177960af40dd2af904be084c3dd366c
downloadaur-8bf31b88f3311c7a7d08f78a955d229f681d2e2b.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD17
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8237f6117a36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = square1-wad
+ pkgdesc = The Adventures of Square, Episode 1 game data
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://adventuresofsquare.com/
+ arch = any
+ license = CCPL:by-nc
+ license = MIT
+ source = http://adventuresofsquare.com/downloads/square-ep1-win32-1.3.zip
+ sha256sums = d0487d9109c4c5016a32b7e1b542c159c329b4ec8f0d89990be8314d8a61fcba
+
+pkgname = square1-wad
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5642e2f2619b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/*.tar.gz
+/*.tar.bz2
+/*.tar.xz
+/*.zip
+/*.7z
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48d41f6899aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Jan Cholasta <grubber at grubber cz>
+
+pkgname=square1-wad
+pkgver=1.3
+pkgrel=1
+pkgdesc="The Adventures of Square, Episode 1 game data"
+arch=('any')
+url='http://adventuresofsquare.com/'
+license=('CCPL:by-nc' 'MIT')
+source=("http://adventuresofsquare.com/downloads/square-ep1-win32-${pkgver}.zip")
+sha256sums=('d0487d9109c4c5016a32b7e1b542c159c329b4ec8f0d89990be8314d8a61fcba')
+
+package() {
+ install -D -m644 'square1.pk3' "${pkgdir}/usr/share/doom/square1.pk3"
+
+ install -D -m644 'SQUARE-LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/SQUARE-LICENSE.txt"
+}