summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikuro Kagamine2018-11-30 19:37:59 +1000
committerMikuro Kagamine2018-11-30 19:37:59 +1000
commit2274d05a0adb8adf7fc75c8533bdd869812ae7d1 (patch)
treebb4bfeee1649deef97047925c5a4f94e522c7e43
parent49bf3f80e1d62101995a65c13ab7f3fd12feee56 (diff)
downloadaur-2274d05a0adb8adf7fc75c8533bdd869812ae7d1.tar.gz
add patch for glibc compat
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f092b5c88dfd..047de6e76d6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = squashfs-tools-git
pkgdesc = Tools for squashfs, a highly compressed read-only filesystem for Linux.
- pkgver = 1806.fb33dfc
+ pkgver = 1808.6e242dc
pkgrel = 1
url = https://github.com/plougher/squashfs-tools
arch = x86_64
@@ -13,7 +13,9 @@ pkgbase = squashfs-tools-git
provides = squashfs-tools
conflicts = squashfs-tools
source = squashfs-tools::git+https://github.com/plougher/squashfs-tools.git
- md5sums = SKIP
+ source = glibc-compat.patch::https://patch-diff.githubusercontent.com/raw/plougher/squashfs-tools/pull/52.patch
+ sha512sums = SKIP
+ sha512sums = 5c47a63e711ccde0a692c6be89c9d0c3590461458087f114decd404616b7b75d25f05d5e216fd2ffd95e5404f7a27a4837701341337d0faae22d5fe6a1b97da8
pkgname = squashfs-tools-git
diff --git a/PKGBUILD b/PKGBUILD
index 5534ab3560b0..35351db9d68a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=squashfs-tools-git
_pkgbasename=squashfs-tools
-pkgver=1806.fb33dfc
+pkgver=1808.6e242dc
pkgrel=1
pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
url="https://github.com/plougher/squashfs-tools"
@@ -16,21 +16,28 @@ arch=('x86_64')
depends=('zlib' 'lzo' 'xz' 'lz4' 'zstd')
conflicts=('squashfs-tools')
provides=('squashfs-tools')
-source=("squashfs-tools::git+https://github.com/plougher/squashfs-tools.git")
-md5sums=('SKIP')
+source=("squashfs-tools::git+https://github.com/plougher/squashfs-tools.git"
+ "glibc-compat.patch::https://patch-diff.githubusercontent.com/raw/plougher/squashfs-tools/pull/52.patch")
+sha512sums=('SKIP'
+ '5c47a63e711ccde0a692c6be89c9d0c3590461458087f114decd404616b7b75d25f05d5e216fd2ffd95e5404f7a27a4837701341337d0faae22d5fe6a1b97da8')
pkgver() {
cd ${_pkgbasename}
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
+prepare() {
+ cd "${srcdir}"/${_pkgbasename}
+ patch -Np1 -i ../glibc-compat.patch
+}
+
build() {
- cd "$srcdir"/${_pkgbasename}/${_pkgbasename}
- CFLAGS="$CFLAGS -O2" make XZ_SUPPORT=1 LZO_SUPPORT=1 LZMA_XZ_SUPPORT=1 LZ4_SUPPORT=1 ZSTD_SUPPORT=1
+ cd "$srcdir"/${_pkgbasename}/${_pkgbasename}
+ CFLAGS="$CFLAGS -O2" make XZ_SUPPORT=1 LZO_SUPPORT=1 LZMA_XZ_SUPPORT=1 LZ4_SUPPORT=1 ZSTD_SUPPORT=1
}
package() {
- cd "$srcdir"/${_pkgbasename}/${_pkgbasename}
- install -Dm755 mksquashfs "$pkgdir"/usr/bin/mksquashfs
- install -m755 unsquashfs "$pkgdir"/usr/bin/unsquashfs
+ cd "$srcdir"/${_pkgbasename}/${_pkgbasename}
+ install -Dm755 mksquashfs "$pkgdir"/usr/bin/mksquashfs
+ install -m755 unsquashfs "$pkgdir"/usr/bin/unsquashfs
}